Ask Your Question
0

octavia loadbalancer ip (198.51.100.1) is given by noop_driver

asked 2018-10-04 06:32:12 -0600

esxzawq gravatar image

openstack loadbalancer create --name lb1 --vip-subnet-id selfservice command will get an ip from noop_driver (198.51.100.1) which is out of my selfservice network ip range

noop_driver and neutron both are available :

/usr/lib/python2.7/site-packages/octavia/network/drivers/noop_driver

/usr/lib/python2.7/site-packages/octavia/network/drivers/neutron

but octavia use noop_driver in octavia.conf

amphora_driver = amphora_noop_driver

compute_driver = compute_noop_driver

network_driver = network_noop_driver

distributor_driver = distributor_noop_driver

how can I made openstack to use neutron driver for octavia

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2018-10-04 17:24:04 -0600

johnsom gravatar image

Oh, It looks like you have an un-configured Octavia deployment.

The noop or no-op drivers are there for testing. They accept requests, but don't actually provision any resources from the other services.

It might help to look at the configuration file from one of our gate tests: http://logs.openstack.org/24/604924/1...

This should give you an idea of the required settings. Note that many of the timeouts are excellently high for the gate tests and should be adjusted for your environment once you are done testing.

Michael

edit flag offensive delete link more

Comments

thanks Michael it works by adding some modification to the octavia.conf based on your conf file. it got a correct ip address from the neutron dhcp but the provisioning_status has stucked on PENDING_CREATE worker.log : Could not connect to instance. Retrying.: ... [Errno 113] No route to host

esxzawq gravatar imageesxzawq ( 2018-10-05 14:21:43 -0600 )edit

it wants to connect to the instance that has been created the ip's are in the range of 192.168.100.0/24 network ( selfservice net) that naturally these ip's are not routable unless by adding floating ip from my provider network

esxzawq gravatar imageesxzawq ( 2018-10-05 14:28:27 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-10-04 06:32:12 -0600

Seen: 40 times

Last updated: Oct 04