Ask Your Question
0

tripleo single-nic-vlans ip not assigned based on subnet in network_environment file

asked 2018-10-04 04:38:54 -0600

akarki gravatar image

Hi, I am trying to deploy openstack on predeployed servers: I have 3 nics:

a) nic1 as controlplane intreface(192.168.24.0/24) (connected to access port)

b) nic2 as vlan network interface(vlanid used: 1001,1002,1005,1700,1705)

c) nic3 for external network so as to install basic packges during deloyment(172.16.141.0/24)(connected to access port)

The network-isolation file used: http://paste.openstack.org/show/731457/

The network-enviroment file used: http://paste.openstack.org/show/731456/

The "ctlplane-assignments.yaml" file used: http://paste.openstack.org/show/731459/

The nic-config/controller used: http://paste.openstack.org/show/731460/

The nic-config/compute used: http://paste.openstack.org/show/731461/

The node-info.yaml used: http://paste.openstack.org/show/731463/

Cmmand used:

openstack overcloud deploy --templates --disable-validations -e /usr/share/openstack-tripleo-heat-templates/environments/deployed-server-environment.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/deployed-server-bootstrap-environment-centos.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/deployed-server-pacemaker-environment.yaml -e node-info.yaml -e network-isolation.yaml -e network-environment.yaml -e ctlplane-assignments.yaml -r /usr/share/openstack-tripleo-heat-templates/deployed-server/deployed-server-roles-data.yaml

Issue is the vlan interfaces creted all have the ip of ctlplane and not from the subnet defined in network-enviroment.yaml.: http://paste.openstack.org/show/731464/

Also the hosts file shows some ip for overcloud from the subnet defined bu does not get attached to the inteface, hosts file: http://paste.openstack.org/show/731466/

os-net-config/config.json file: http://paste.openstack.org/show/731468/

The thing to worry is it gets all the vlan info and default route correctly however it just seems not to get the interfcae ip correctly.

Please help

edit retag flag offensive close merge delete

Comments

Remove the line use_dhcp: false from the ovs_bridge used by vlans for both controller and compute nic-config files. I think that should solve your problem.

codylab gravatar imagecodylab ( 2018-10-04 08:13:29 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2018-10-04 08:20:59 -0600

codylab gravatar image
...
    - type: ovs_bridge
      name: bridge_name
    # use_dhcp: false # remove this line from controller and compute nic-config files
      dns_servers:
      get_param: DnsServers 
...
edit flag offensive delete link more

Comments

Hi cody, actualy use_dhcp was added by me..for reason that without it use_dhcp the error was sameso it thought about adding it.. Also in neutron net-show for undercloud i only see ctlplane network can that be an issue??

akarki gravatar imageakarki ( 2018-10-04 08:35:23 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-10-04 04:38:54 -0600

Seen: 41 times

Last updated: Oct 04