Ask Your Question
0

designate client 2.8 for pike - Bug 1714460 [closed]

asked 2018-10-01 07:46:00 -0500

Robby gravatar image

Hello there, I am facing exact issue as discussed in this bug https://bugs.launchpad.net/python-designateclient/+bug/1714460 (https://bugs.launchpad.net/python-des...) and the solution given is using python-designateclient 2.8. I am using openstack pike on Centos, which does not have 2.8, see below link. https://releases.openstack.org/teams/designate.html (https://releases.openstack.org/teams/...).

Please suggest me amicable solution, other than upgrading to queens. Like editing some files.

Any help is much appreciated

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Robby
close date 2019-06-26 02:53:03.458517

1 answer

Sort by ยป oldest newest most voted
0

answered 2018-10-01 08:38:14 -0500

Check out https://review.openstack.org/#/c/500003/. The fix consists of 2 lines in a file named exceptions.py. It should not be too hard to identify the lines in your version of the client and apply the same fix.

edit flag offensive delete link more

Comments

I tried the link edited the exceptions.py, I had seen only one line to edit class RemoteError(Base): def __init__(self, message=None, code=None, type=None, errors=None, *request_id=None, *ignore): err_message = self._get_error_message(message, type, errors)

Robby gravatar imageRobby ( 2018-10-01 09:12:15 -0500 )edit

know its saying :

openstack dns service list

The server is currently unavailable. Please try again at a later time.

did I missed anything?

Robby gravatar imageRobby ( 2018-10-01 09:13:19 -0500 )edit

One of us misses something, not sure who. I can't say where this comes from. Perhaps adding --debug helps understanding the error.

Another option might be replacing the python-designate client using pip install. I am not sure if you risk overwriting other files this way.

Bernd Bausch gravatar imageBernd Bausch ( 2018-10-01 20:50:48 -0500 )edit

See https://docs.openstack.org/python-des.... You can also select a specific version of the client, but I don't know the pip install option by heart.

Bernd Bausch gravatar imageBernd Bausch ( 2018-10-01 20:51:31 -0500 )edit

Thanks much for your time, could you please paste the two lines here, as I can only see one line to edit and I did it.

Robby gravatar imageRobby ( 2018-10-02 02:39:16 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2018-10-01 07:46:00 -0500

Seen: 48 times

Last updated: Oct 01 '18