Ask Your Question
0

Enable router panel on Horizon

asked 2018-09-24 21:05:29 -0600

fsalaman gravatar image

Hi! Recently I enabled routing on a 2 node Openstack Newton cluster, now routing works fine.

But Horizon is not showing the routers panel so I can only work with routers vía CLI and regular users will use this platform, and we don't expect them to use CLI. How to enable this panel?

Thanks!!!

edit retag flag offensive close merge delete

2 answers

Sort by » oldest newest most voted
2

answered 2018-09-25 04:01:46 -0600

updated 2018-09-25 04:04:54 -0600

On a Rocky Devstack, I have this in .../openstack_dashboard/local/local_settings.py:

OPENSTACK_NEUTRON_NETWORK = {
    'enable_router': True,

To test this, I set it to False and restarted the web server. As expected, the router panel disappeared. Set it back to True, restarted Apache, and it was back.

edit flag offensive delete link more
0

answered 2018-09-25 13:03:41 -0600

fsalaman gravatar image

Thanks a lot! That made the trick, tadaa!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-09-24 21:05:29 -0600

Seen: 216 times

Last updated: Sep 25