neutron cannot ping external (

asked 2018-09-23 05:13:57 -0500

raniaadouni gravatar image

updated 2018-09-23 07:19:29 -0500

Hi , EVERYONE I am using openstack pike version with compute and contoller node so I did configure neutron like the documentation of openstack but when I lunch instance and associate the floating ip but when I try ping it stuck there I try to ping the gateway of the router it work fine , So I am wondering where is the problem !! for my environment I am using 2 physical Pc and I have Virtual machine for the compute node on the pc 1 and vm for the controller on pc2 and they are connected with cable Ethernet , So each VM have 2 NIC exemple for the controller node :

one for the local (

auto ens33
iface ens33 inet static

and the second Nic (NAT )

auto ens34
iface ens34 inet manual
up ip link set dev $IFACE up
down ip link set dev $IFACE down

!! any Help to get through this please !!!

edit retag flag offensive close merge delete


The mapping to the external network may be incorrect. Double-check flat_networks in ml2_conf.ini and physical_interface_mappings in linuxbridge_agent.ini. The external network must map to ens33.

The controller should have a bridge named brq.... into which ens33 is plugged.

Bernd Bausch gravatar imageBernd Bausch ( 2018-09-23 08:42:12 -0500 )edit

but in the documentation of openstack pike with the option 2 self service network , it is mentioned for the file linuxbridge_agent.ini to put physical_interface_mappings = provider:PROVIDER_INTERFACE_NAME , So I put provider:ens34 and for the bridge named brq I didn't do it because I didn't see it.

raniaadouni gravatar imageraniaadouni ( 2018-09-23 08:53:25 -0500 )edit

I confused the two interfaces, sorry. ens34 seems to be correct in your case.

You don't configure the brq bridge, Neutron does it. Can you see it (brctl show command)? If not, the router is not connected to ens34. Also, are you certain that you can reach the internet from ens34?

Bernd Bausch gravatar imageBernd Bausch ( 2018-09-23 09:35:05 -0500 )edit

yes the problem that in my controller or my compute node I can reach the INTERNET because the ens34 is not configure to have an ip address and for the ens33 is a local address , SO if I don't add another nic like this :auto ens35 iface ens35 inet dhcp , I can downland all the package that I need .

raniaadouni gravatar imageraniaadouni ( 2018-09-23 10:14:31 -0500 )edit

It is get me so confuse the nic ens34 why I don't just configure and add a normal public address !!

raniaadouni gravatar imageraniaadouni ( 2018-09-23 10:16:14 -0500 )edit