Ask Your Question
0

NoneType has no attribute 'get_user_id'

asked 2018-09-14 11:37:23 -0600

Fishbone gravatar image

Hello all
I have murano-api and murano-engine setup and upgraded from ocata to queens. Since the upgrade I have not been able to launch any environments. There were many issues with the keystone config that forced me to not follow documentation from openstack docs and I instead needed to use the password auth_type in the config.
Regardless of this I maintain the error when launching an environment:
"NoneType has no attribute 'get_user_id'"
I have tried recreating the murano database, reinstalling murano from apt repository and reinstalling murano from the git repository and the problem persists.
Please help. This has been like this for a while.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2018-09-24 21:34:32 -0600

jmguzman gravatar image

I have the same issue. Did you manage to find a solution?

edit flag offensive delete link more

Comments

Probably It has to be right set [murano_auth] section in murano.conf instead of [keystone_authtoken] ( better to use both sections) and set right endpoint for keystone auth and user_domain

lukaslemes gravatar imagelukaslemes ( 2018-09-26 12:22:55 -0600 )edit

[murano_auth]

auth_uri = http://<keystone_endhost>t:5000/v3 auth_url = http://<keystone_endhost>:5000/v3 auth_type = password username = murano user_domain_name = Default

lukaslemes gravatar imagelukaslemes ( 2018-09-26 12:26:32 -0600 )edit

[keystone_authtoken] auth_url = http://<keystone_endhost>:5000 www_authenticate_uri = http://<keystone_endhost>:5000/ auth_uri = http:/<keystone_endhost>:5000/v3 auth_type = password service_token_roles = service service_token_roles_required = true

lukaslemes gravatar imagelukaslemes ( 2018-09-26 12:34:55 -0600 )edit

These options resolved My issue thank you very much!!! @lukaslemes

Fishbone gravatar imageFishbone ( 2018-10-16 20:26:20 -0600 )edit
1

answered 2018-09-25 07:46:59 -0600

lukaslemes gravatar image

Hi, probably broken trusted keystone login, because when u set use_trusts = false in murano.conf, then it's ok. Or set some config value for trusted in murano.conf, but i dont find out what value so far

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2018-09-14 11:37:23 -0600

Seen: 46 times

Last updated: Sep 24