Ask Your Question
0

Can´t create k8s cluster in magnum, image issue

asked 2018-09-12 17:02:48 -0500

fsalaman gravatar image

updated 2018-09-12 17:03:33 -0500

Hi!

I get the following error:

  $ magnum cluster-template-create --keypair ckey --external-network public --master-flavor m1.small --flavor m1.small --image-id 33084ac8-4a51-4c53-950c-b418fc0eb4db --name PaaSFabs1 --fixed-network nuonet1 --public --coe kubernetes
  WARNING: The --image-id parameter is deprecated and will be removed in a future release. Use the --image parameter to avoid seeing this message.
  WARNING: The magnum client is deprecated and will be removed in a future release.
  Use the OpenStack client to avoid seeing this message.
  WARNING: The --name parameter is deprecated and will be removed in a future release. Use the <name> positional parameter to avoid seeing this message.
  ERROR: Cluster type (vm, None, kubernetes) not supported (HTTP 400) (Request-ID: req-06a309aa-b2ae-4a5f-ace7-bebb148445cd)

Why is the magnum cli not passing the image-id? I also tried --image with the image name, and I get (vm, None, kubernetes), where None is no image, right?

BTW, I am using packstack-Queens on CentOS 7 OS as Openstack host, 2 nodes, I can launch VMs with no issues, Neutron networks work just fine,

Thanks and please help me!

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2018-09-13 00:35:08 -0500

Why is the magnum cli not passing the image-id?

It is. It just issues a warning that the image-id option will disappear in the future. By the way, the openstack client seems to have Magnum commands as well; try openstack help coe.

ERROR: Cluster type (vm, None, kubernetes) not supported

To use an image in Magnum, it must have the os_distro property. The second value in the cluster type, in your case None, is os_distro, and the error message indicates that your image doesn't have the property. The documentation lists accepted values.

You can update your image with openstack image set --property os_distro=fedora-atomic 33084ac8-4a51-4c53-950c-b418fc0eb4db.

edit flag offensive delete link more

Comments

That made it, thanks a lot! :) :)

fsalaman gravatar imagefsalaman ( 2018-09-13 09:36:27 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-09-12 17:02:48 -0500

Seen: 23 times

Last updated: Sep 13