enable external network endpoint in tripleo

asked 2018-09-06 03:59:20 -0600

akarki gravatar image

Hi, We are trying to install tripleo in our lab netwwork with 2 nic: 1) external network(172.16.141.0/24) 2) provicioning network(192.168.24.0/24)

So we have to enable external network endpoints so for that we use the undercloud.conf given below:

# Config generated by undercloud wizard
# Use these values in undercloud.conf
[DEFAULT]
undercloud_hostname = myhost.mydomain
local_interface = em1
local_mtu = 1500
network_cidr = 192.168.24.0/24
masquerade_network = 192.168.24.0/24
local_ip = 192.168.24.1/24
network_gateway = 192.168.24.1
undercloud_public_host = 172.16.141.149
undercloud_admin_host = 172.16.141.150
undercloud_service_certificate =
generate_service_certificate = False
scheduler_max_attempts = 10
dhcp_start = 192.168.24.4
dhcp_end = 192.168.24.15
inspection_iprange = 192.168.24.16,192.168.24.50
# Deprecated names for compatibility with older releases
discovery_iprange = 192.168.24.16,192.168.24.50
undercloud_public_vip = 172.16.141.149
undercloud_admin_vip = 172.16.141.150

We set undercloud_public_vip ,undercloud_admin_vip ,undercloud_public_host ,undercloud_admin_host to external network. But the openstack endpoint list only shows endpoint in 192.168.0/24 subnet.

Is there any other configuration that we need to do..please help.

Also whats the use of floating ip in overcloud nodes??

Thanks in advance

edit retag flag offensive close merge delete

Comments

You need to have SSL/TLS configured in order to use public endpoint on the undercloud. Change generate_service_certificate = True and then do openstack undercloud upgrade. If unable to upgrade, re-install the undercloud.

codylab gravatar imagecodylab ( 2018-09-06 07:30:25 -0600 )edit

In short, the floating IP provides a 1-to-1 NAT on neutron router for the applied VM, so that external connections (e.g. from Internet) can reach the VM via a floating IP (which is a publicly routable one). It is the same as the "Elastic IP" in AWS.

codylab gravatar imagecodylab ( 2018-09-06 07:44:48 -0600 )edit

thanks coby is the undercloud.conf correct other than generate_service_certificate = True??

akarki gravatar imageakarki ( 2018-09-06 08:25:50 -0600 )edit

Seems alright to me.

codylab gravatar imagecodylab ( 2018-09-06 09:09:15 -0600 )edit