Ask Your Question
0

devstack install error

asked 2014-02-07 02:55:34 -0500

jaguar gravatar image

Hi,

I just made a fresh install of devstack on centos 6.5 by logging into my centos vm on virtualbox, and without going into any directories, did the git clone, ran the create user script, su stack, ran the stack.sh script. it went without any errors that i detected and said completed in 8XX seconds, I then tried to connect to horizon via firefox and could not connect, even though i could ping the vm.

I then tried running the destroy script and reinstalling multiple times, but I still cannot connect to the web server.

Any help would be appreciated as I am fairly new to linux and I am really trying to learn how to use it along with many of the amazing applications like openstack.

Thank You

edit retag flag offensive close merge delete

Comments

Is your apache web service running? Use "sudo service apache2 start"

prasoontelang gravatar imageprasoontelang ( 2014-02-07 05:12:43 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-02-23 14:28:15 -0500

Rakesh Patnaik gravatar image

can you please check port forwarding is enabled on VirtualBox VM. Settings -> Network -> Adapter -> Port forwarding button You will need a forward from port 80 on the guest VM to a port lets say 8080 on you host machine. You would then access horizon dashboard using http://localhost:8080

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-02-07 02:55:34 -0500

Seen: 228 times

Last updated: Feb 23 '15