Nova requires QEMU version 2.5.0: how do we get that in Centos?

asked 2018-09-04 02:26:56 -0500

ns1-sundar gravatar image

In a devstack setup, the n-cpu service fails to start with the error:

InternalError: Nova requires QEMU version 2.5.0 or greater.

This message comes from: https://github.com/openstack/nova/blob/master/nova/virt/libvirt/driver.py#L512 (https://github.com/openstack/nova/blo...)

The EPEL repo provides the qemu package with version 2.0.0. Following the reply in: https://stackoverflow.com/questions/49939786/nova-compute-service-throwing-error-nova-requires-qemu-version-2-1-0-or-greater (https://stackoverflow.com/questions/4...) :

I removed the qemu-system-x86 package and tried installing centos' qemu-kvm-ev package. However, n-cpu fails to start because it cannot find qemu-system-x86_64 binary. The qemu-[kvm-]ev packages from Centos do not seem to provide that binary.

What is the way out?

Thanks, Sundar

edit retag flag offensive close merge delete

Comments

Is something blocking the moderation of this question? How do I reach the moderators?

ns1-sundar gravatar imagens1-sundar ( 2018-09-04 18:15:37 -0500 )edit