Failed to create resource provider Compute [closed]

asked 2018-09-03 08:28:16 -0500

Behzad_awesome gravatar image

updated 2018-09-03 16:30:52 -0500

Dear experts,

As I was about to integrate the Nova compute to the controller node, I am experiencing some sort of error as I restart he nova-compute on the compute node which is as follow:

My OS: Ubuntu Xenial Openstack release: Queens

root@Compute:~# service nova-compute restart the content of the /var/log/nova/nova-compute.log shows the following error:

**Error updating resources for node Compute.: ResourceProviderCreationFailed: Failed to create resource provider Compute**
2018-09-03 11:54:03.187 6910 ERROR nova.compute.manager Traceback (most recent call last):
***********content omitted for brevity************
2018-09-03 11:54:03.187 6910 ERROR nova.compute.manager     name=name or uuid)
**2018-09-03 11:54:03.187 6910 ERROR nova.compute.manager ResourceProviderCreationFailed: Failed to create resource provider Compute**
2018-09-03 11:54:03.187 6910 ERROR nova.compute.manager

The other form is when I run the following command on the Nova Compute node, it shows the exact problem: nova-status upgrade check However, on the controller node, the command shows that everything is okay.

It worth to mention that in the controller I can see the nova compute node and there is no firewall or connectivity problem between compute and the controller node.

on the controller node:

root@Controller:~# openstack compute service list --service nova-compute
+----+--------------+---------+------+---------+-------+----------------------------+
| ID | Binary       | Host    | Zone | Status  | State | Updated At                 |
+----+--------------+---------+------+---------+-------+----------------------------+
|  6 | nova-compute | Compute | nova | enabled | up    | 2018-09-03T07:50:08.000000 |
+----+--------------+---------+------+---------+-------+----------------------------+
root@Controller:~#

any help is much appreciated.

Regards Behzad

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Behzad_awesome
close date 2018-09-04 00:17:45.942264

Comments

1

Is the placement service running? If yes, what does its log say?

Are there messages about the placement service in the compute log?

Perhaps what you cut for brevity contains relevant information.

Bernd Bausch gravatar imageBernd Bausch ( 2018-09-03 16:30:50 -0500 )edit

thanks for the response, and thanks for highlighting the placement service. My problem is solved and the root cause was I had some typing error in for the placement argument in the Nova compute node. Thanks you.

Behzad_awesome gravatar imageBehzad_awesome ( 2018-09-04 00:16:39 -0500 )edit