Volume did not finish being created even after we waited some seconds

asked 2018-08-24 08:54:25 -0600

dhh3k4 gravatar image

updated 2018-09-10 12:32:15 -0600

I am using Openstack Pike on Ubuntu 16.04 (built from devstack) and my network ethernet is 10Gbps. I try to launch a windows server 2012 instance and got an error.

Message Build of instance 180a99b7-42a9-4ea8-a735-f5d869a4c5da aborted: Volume 657a978f-b880-47ec-b651-5fee188872e8 did not finish being created even after we waited 0 seconds or 1 attempts. And its status is error. Code 500 Details File "/opt/stack/nova/nova/compute/manager.py", line 1840, in _do_build_and_run_instance filter_properties) File "/opt/stack/nova/nova/compute/manager.py", line 2028, in _build_and_run_instance phase=fields.NotificationPhase.ERROR, exception=e) File "/usr/local/lib/python2.7/dist-packages/oslo_utils/excutils.py", line 220, in __exit__ self.force_reraise() File "/usr/local/lib/python2.7/dist-packages/oslo_utils/excutils.py", line 196, in force_reraise six.reraise(self.type_, self.value, self.tb) File "/opt/stack/nova/nova/compute/manager.py", line 1984, in _build_and_run_instance block_device_mapping) as resources: File "/usr/lib/python2.7/contextlib.py", line 17, in __enter__ return self.gen.next() File "/opt/stack/nova/nova/compute/manager.py", line 2173, in _build_resources reason=e.format_message()) Created Aug. 24, 2018, 8:34 a.m.

I added three lines in [DEFAULT] tag in the nova config at /etc/nova/nova.conf




I also checked /etc/cinder/cinder.conf and saw image_volume_cache_enabled = True. But the problem stil occurs

Is there anyone get same problem? May I get some solutions for this case?

edit retag flag offensive close merge delete


If you are still struggling with this problem: My guess is that the volume could not be created at all. The 0 seconds mentioned in the error log and the reference to volume's ERROR status indicate that.

Use openstack volume show to find out why the volume is in ERROR. Perhaps you have no space.

Bernd Bausch gravatar imageBernd Bausch ( 2018-09-10 12:33:54 -0600 )edit

2 answers

Sort by ยป oldest newest most voted

answered 2018-09-10 09:11:21 -0600

yasin lachiny gravatar image

you should add block_device_allocate_retries=300 to compute node it is better to built a volume from that image and after that launch instance

edit flag offensive delete link more

answered 2019-10-17 03:00:45 -0600

grkim gravatar image

I have same issue. have you solve problem?

edit flag offensive delete link more


I have solved it. when you create instance, do not use "create new volume -> yes" just create instance without create new volume .

grkim gravatar imagegrkim ( 2019-10-31 08:01:10 -0600 )edit

This worked for me

Launch Instance --> Source --> Select boot Source - Image --> Create New Volume "No"

I'm not sure why I can't create a new volume though. Maybe I need to configure an lvm group in devstack?

Jwoozy gravatar imageJwoozy ( 2020-04-02 17:16:58 -0600 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2018-08-24 08:54:25 -0600

Seen: 11,565 times

Last updated: Oct 17 '19