Ask Your Question
0

The VMs cannot access the Internet after installing the OpenStack via Kolla-ansible

asked 2018-08-23 04:20:17 -0500

TripleZ gravatar image

Here are the networks in my clusters.

https://i.redd.it/v599767o0th11.png (image description)

I have successfully deployed the OpenStack via the kolla-ansible tool. However, when I ran over the init-runonce script, I found the VM cannot access to the Internet.

Here are the network info in the Controller node:

[root@Controller01 ~]# ip addr
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 40:f2:e9:c7:4f:ca brd ff:ff:ff:ff:ff:ff
    inet 211.65.102.41/24 brd 211.65.102.255 scope global eno1
       valid_lft forever preferred_lft forever
    inet6 fe80::2052:2312:8fb4:e5dd/64 scope link
       valid_lft forever preferred_lft forever
3: eno2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master ovs-system state UP group default qlen 1000
    link/ether 40:f2:e9:c7:4f:cb brd ff:ff:ff:ff:ff:ff
    inet6 fe80::42f2:e9ff:fec7:4fcb/64 scope link
       valid_lft forever preferred_lft forever
4: ens6f0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 00:0e:1e:b9:4f:a0 brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.41/24 brd 10.0.0.255 scope global ens6f0
       valid_lft forever preferred_lft forever
    inet 10.0.0.254/32 scope global ens6f0
       valid_lft forever preferred_lft forever
    inet 211.65.102.70/32 scope global ens6f0
       valid_lft forever preferred_lft forever
    inet6 fe80::f0a5:bac4:b28b:e059/64 scope link
       valid_lft forever preferred_lft forever
5: ens6f1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 00:0e:1e:b9:4f:a2 brd ff:ff:ff:ff:ff:ff
    inet 10.1.0.41/24 brd 10.1.0.255 scope global ens6f1
       valid_lft forever preferred_lft forever
    inet6 fe80::3f05:a32:63fb:eec5/64 scope link
       valid_lft forever preferred_lft forever
6: enp0s20u1u5: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 1000
    link/ether 42:f2:e9:c7:4f:cf brd ff:ff:ff:ff:ff:ff
7: docker0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default
    link/ether 02:42:bc:1e:8c:ef brd ff:ff:ff:ff:ff:ff
    inet 172.17.0.1/16 scope global docker0
       valid_lft forever preferred_lft forever
    inet6 fe80::42:bcff:fe1e:8cef/64 scope link
       valid_lft forever preferred_lft forever
168: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether d6:f8:ee:1d:5e:5d brd ff:ff:ff:ff:ff:ff
169: br-ex: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 40:f2:e9:c7 ...
(more)
edit retag flag offensive close merge delete

Comments

we have the same problem and I'm still trying to find out why

vblando gravatar imagevblando ( 2019-04-14 02:16:54 -0500 )edit

1 answer

Sort by ┬╗ oldest newest most voted
0

answered 2019-05-20 11:42:23 -0500

shotoflove gravatar image

https://ask.openstack.org/en/question/117748/kolla-ansible-instance-no-internet/ (https://ask.openstack.org/en/question...) VirtualBox needed promiscious mode allow all for me.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-08-23 04:20:03 -0500

Seen: 62 times

Last updated: Aug 23 '18