Ask Your Question
0

External network fails after creating OVS bridge

asked 2018-08-20 14:38:57 -0500

trilliams gravatar image

updated 2018-08-20 14:40:16 -0500

Hey folks,

I’ve been trying for a while now to install OpenStack using packstack-queens on several different devices, but installation keeps failing due to external networking dying after OVS creates the br-ex bridge. Once install completes/fails I can ping gw but can’t reach anything external until I restart network.service. I’ve tried the setup on three separate Intel i5 NUCs & a laptop (all with 16-32G RAM, 250GB+ disk) & keep running into the same error on all boxes. Oddly enough, installation works like a charm on KVM & even on AWS ec2, but not on bare metal. Would someone mind helping me out?

Here’s an outline of my latest attempt:

OS: CentOS 7.5, RAM: 32G, Disk: 250G

[root@controller ~]# uname -a Linux http://controller.strugglestack.org 3.10.0-862.11.6.el7.x86_64 #1 SMP Tue Aug 14 21:49:04 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Latest error:

ERROR : Error appeared during Puppet run: 192.168.1.172_compute.pp Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install openstack-nova-migration' returned 1: No Presto metadata available for centos-qemu-ev

https://gist.github.com/OGtrilliams/cd96572b257c1f4cd9426a9aea72a4dd (openstack-setup.log (debug))

https://gist.github.com/OGtrilliams/fa4441a8618e4047b9ee89b54e265c94 (Answer file)

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
1

answered 2018-08-23 12:51:24 -0500

AndyW gravatar image

is this the allinone install, and just one NIC ? installing on a 1 vNIC VM should give same problem in theory, no?

have not done bareM install but I used following cmd line (ens3 was my NIC)

sudo packstack --allinone --provision-demo=n --os-neutron-ovs-bridge-mappings=extnet:br-ex --os-neutron-ovs-bridge-interfaces=br-ex:ens3 --os-neutron-ml2-type-drivers=vxlan,flat --os-heat-install=y --default-password=password

(extnet is provider-net definition) then following RDO guidelines, need to config machine a bit (assuming you still have a connection...)

$ sudo systemctl disable firewalld

$ sudo systemctl stop firewalld

$ sudo systemctl disable NetworkManager

$ sudo systemctl stop NetworkManager

$ sudo systemctl enable network

$ sudo systemctl start network

etc/sysconfig/network-scripts/ifcfg-br-ex
DEVICE=br-ex
DEVICETYPE=ovs
TYPE=OVSBridge
USERCTL=no
NAME=br-ex
OVSBOOTPROTO=static
IPADDR=192.168.122.54
NETMASK=255.255.255.0
GATEWAY=192.168.122.1
DNS1=192.168.122.1
OVS_EXTRA="set bridge br-ex other-config:hwaddr=52:54:00:c5:90:8e fail_mode=standalone"
ONBOOT=yes


then set static IP addressing
/etc/sysconfig/network-scripts/ifcfg-ens3 :
DEVICE=ens3
NAME=ens3
DEVICETYPE=ovs
TYPE=OVSPort
OVS_BRIDGE=br-ex
ONBOOT=yes

reboot or sudo service network restart
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2018-08-20 14:38:57 -0500

Seen: 360 times

Last updated: Aug 23 '18