Ask Your Question
0

Horizon: Domain Admin Cannot Create User

asked 2018-08-14 00:25:32 -0600

Mrxlazuardin gravatar image

Hi,

I have setup multi domain environment and do delegation to domain admin. Domain admin can see all things inside its own domain and can manage projects inside its own domain. But, domain admin cannot create users inside its own domain. It seem something wrong with "rule:admin_and_matching_user_domain_id" which is related to "user.domain_id". What is happen on my case?

Best regards,

edit retag flag offensive close merge delete

Comments

What makes you think something is wrong with this rule? What are the symptoms? What messages do you find in Horizon's and Keystone's log files? What do you get when you use the CLI openstack --debug user create?

Bernd Bausch gravatar imageBernd Bausch ( 2018-08-14 01:19:00 -0600 )edit

Hi Bernd,

There in no Create button on Users menu of Horizon if I login with domain admin.

Best regards,

Mrxlazuardin gravatar imageMrxlazuardin ( 2018-08-14 05:09:46 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2018-08-23 06:13:07 -0600

jsm gravatar image

Hi

Can it be you have hit the bugs solved be this commit: https://git.openstack.org/cgit/openst...

the bugs are reported here: https://bugs.launchpad.net/ubuntu/+so... https://bugs.launchpad.net/ubuntu/+so...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2018-08-14 00:25:32 -0600

Seen: 78 times

Last updated: Aug 23