installing glance, greenlet problem

asked 2014-02-06 17:27:53 -0600

mrtigi gravatar image


i'm using debian (7.0 a.k.a. wheezy). and was following your guide. At the part of installing the image service i ran into a problem. When trying to install glance it gave me an error, namely that it depends on glance-api and glance-registry, so i tried installing glance-common. Turns out this depends on python-glance so i tried installing that, and that's where the problem starts. This package depends on python-greenlet, which is installed but the error said: "depends: python-greenlet (>=0.3.2) but 0.3.1-2.5 is to be installed". now i've tried many things, apt-get update, upgrade, pip install greenlet, installing the dev version of greenlet and then some more minor things i've forgotten at the moment, but nothing seems to work. Does anyone have an idea how to fix this problem ?

I would be most grateful.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted

answered 2014-11-21 10:02:45 -0600

aelochamul gravatar image

I has the same problem, try to install this three dependences, after install Galnce:

python-greenlet: you'll find it here: ( libxml2-dev: is necesary to install the last one of this list: ( libxslt1.1: (

Before to install, all the links are for Debian Wheezy Installing the packets: wget "url-off-the-packet" dpkg -i "packet"


aptitude install glance or apt-get install glance

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2014-02-06 17:27:53 -0600

Seen: 298 times

Last updated: Feb 06 '14