Ask Your Question
0

Cloud-init on centos not able to reach metadata services

asked 2018-08-06 17:23:45 -0600

xwolv1994 gravatar image

updated 2018-08-06 17:25:19 -0600

Hi, I am using heat template to create virtual machines which has no cloud-config or user-data parameters. Later I am using serial console to telnet into virtual machines. Upon boot the console is flooded with cloud-init messages like example: cloud-init[1079]: 2018-08-06 21:15:16,965 - url_helper.py[WARNING]: Calling 'http://6.6.6.2//latest/meta-data/instance-id' failed [70/120s]: unexpected error ['NoneType' object has no attribute 'status_code'] This is messing up with the telnet session which is a expect script. Is there any way that this can be prevented like disabling cloud-init on instance boot or with some user-data and cloud-config parameters.

Thank you

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2018-08-06 18:46:58 -0600

According to the cloud-init documentation, you can disable cloud-init by creating a file /etc/cloud/cloud-init.disabled or by adding cloud-init=disabled to the kernel command line.

AFAIK this requires tweaking the image. You can use the libguestfs-tools to create that file and/or change the kernel parameters. I don't think there is a mechanism in Nova or Glance to submit a modified kernel command line.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-08-06 17:23:45 -0600

Seen: 67 times

Last updated: Aug 06