Keystone issue (HTTP 500)- Queens release

asked 2018-07-18 09:22:34 -0500

Hi all, I am new to Openstack and attempting a manual installation of Queens release on Ubuntu 16.04 LTS. I am following the installation guide at https://docs.openstack.org/install-gu.... I have been able to setup the environment, i.e. install and configure etcd, mariadb, memcached, etc.

I was trying to install the keystone service based on the instructions in https://docs.openstack.org/keystone/q.... In the next page, after running the command:

$ openstack domain create --description "An Example Domain" example

I get an error:

An unexpected error prevented the server from fulfilling your request. (HTTP 500) (Request-ID: req-12285842-14d8-45d4-9b31-8573482856e3)

I have seen existing posts in the forum (such as https://ask.openstack.org/en/question... and https://ask.openstack.org/en/question... ) about a similar error but I haven't found a clear solution. Moreover, the root cause in my case may be different based on the error logs I observed. I checked keystone-wsgi-public.log and here is a brief output:

2018-07-18 15:46:04.919 8678 INFO keystone.common.wsgi [req-5e68136c-6c75-4bd7-af06-4c559b5c584b - - - - -] GET http://controller:5000/v3/
2018-07-18 15:46:04.933 8677 INFO keystone.common.wsgi [req-6a85f472-f4f3-4e2d-a1dc-69e86148f2ee - - - - -] POST http://controller:5000/v3/auth/tokens
2018-07-18 15:46:04.941 8677 ERROR keystone.common.wsgi [req-6a85f472-f4f3-4e2d-a1dc-69e86148f2ee - - - - -] Can't load plugin: sqlalchemy.dialects:mysql.pymsql: NoSuchModuleError: Can't load plugin: sqlalchemy.dialects:mysql.pymsql
2018-07-18 15:46:04.941 8677 ERROR keystone.common.wsgi   File "/usr/lib/python2.7/dist-packages/keystone/common/wsgi.py", line 226, in __call__
2018-07-18 15:46:04.941 8677 ERROR keystone.common.wsgi     result = method(req, **params)
2018-07-18 15:46:04.941 8677 ERROR keystone.common.wsgi   File "/usr/lib/python2.7/dist-packages/keystone/auth/controllers.py", line 113, in authenticate_for_token
    2018-07-18 15:46:04.941 8677 ERROR keystone.common.wsgi     auth_info = core.AuthInfo.create(auth=auth)
...
...

It seems that the plugin "sqlalchemy.dialects:mysql.pymsql" could not be loaded.

Could anyone point out the reason for this issue and any suggestion to resolve it ?

Thanks

edit retag flag offensive close merge delete