Ask Your Question
0

Error in installation of packstack: allinone on CentOS 6.5

asked 2014-02-06 05:22:31 -0500

Dheeraj gravatar image

Installing: Clean Up... [ DONE ] Setting up ssh keys... [ DONE ] Discovering hosts' details... [ DONE ] Adding pre install manifest entries... [ DONE ] Adding MySQL manifest entries... [ DONE ] ......... ......... ......... Adding Nagios server manifest entries... [ DONE ]

Adding Nagios host manifest entries... [ DONE ]

Adding post install manifest entries... [ DONE ]

Preparing servers... [ DONE ]

Installing Dependencies... [ DONE ]

Copying Puppet modules and manifests... [ DONE ]

Applying Puppet manifests...

Applying 172.17.15.26_prescript.pp [ ERROR ]

ERROR : Error appeared during Puppet run: 172.17.15.26_prescript.pp

Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install openstack-selinux' returned 1: Error: Cannot find a valid baseurl for repo: base

You will find full trace in log /var/tmp/packstack/20140206-143732-Aq8gdk/manifests/172.17.15.26_prescript.pp.log

Please check log file /var/tmp/packstack/20140206-143732-Aq8gdk/openstack-setup.log for more information

edit retag flag offensive close merge delete

Comments

Could you paste the log information from /var/tmp/packstack/20140206-143732-Aq8gdk/manifests/172.17.15.26_prescript.pp.log ?

Marcos F. Lobo gravatar imageMarcos F. Lobo ( 2014-02-06 05:23:58 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-02-07 05:59:02 -0500

This looks like a fndatmental issue with yum configuration. Can you try to yum install openstack-selinux at the command line. If that doesn't work can you verify that the URLs in all your enabled repos are correct and contactable

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2014-02-06 05:22:31 -0500

Seen: 621 times

Last updated: Feb 07 '14