Cannot Change VNC URL Successfully

asked 2018-07-10 16:54:23 -0600

snowman4839 gravatar image

I'm trying to change the url for VNC from x.x.x.x:6080/vnc_lite.html to x.x.x.x:6080/vnc.html so I can use the full featured NoVNC client. The vnc_lite.html client gives me double typed characters whenever I type mildly fast but this doesn't seem to happen with vnc.html. I can see a session with vnc_lite.html and then change the url to vnc.html without a problem but whenever I set openstack ansible to use nova_novncproxy_base_url: "{{ nova_novncproxy_base_uri }}/vnc.html" instead of nova_novncproxy_base_url: "{{ nova_novncproxy_base_uri }}/vnc_lite.html", I can never get a session to open and it always give that the connection failed.

I looked into it further and saw that nova-consoleauth is giving handler exception: The token 'xxx-xx-x-xxx' is invalid or has expired. Is console auth tied specifically to vnc_lite.html somewhere? Is there anywhere I can set this in openstack ansible? vnc_lite.html continues to work if I manually type it in to the URL but vnc.html never works unless I validate a token first with vnc_lite.html

edit retag flag offensive close merge delete