Only controller can ping instances !

asked 2018-07-04 10:53:45 -0600

amirdhaoui gravatar image

updated 2018-07-05 08:44:31 -0600

I installed OpenStack Queens with one controller and two compute nodes. I used option 2 for networking.

My external network is my physical LAN network. I created a private network and a router to interconnect my two LANs. Ext NET: 192.168.1.0/24 Priv NET: 10.0.0.0/24

I launched an instance and I affected to it a Floating IP. INSTANCE :IP=10.0.0.3, FIP=192.168.2.3 When I want to ping my instance using its FIP from one machine connected to the external network (192.168.1.0/24) it's not working. Only the controller can ping instances. Even compute nodes can't.

Instances can ping the external interface of the router but no more !! and I can't reach internet of course. I think it is a VLAN issue but I am not sure. Any help will be appreciated.

edit retag flag offensive close merge delete

Comments

Without knowing anything about your external network configuration (where do the VLANs come in?), all I can say: Double-check your config files, and trace the traffic to find out where it disappears.

Did you install the cloud on physical or virtual machines?

Bernd Bausch gravatar imageBernd Bausch ( 2018-07-04 18:37:11 -0600 )edit

In particular, check the mapping of the cloud’s external network to your physical network infrastructure, both the configuration files and how you created the external network in the cloud.

Bernd Bausch gravatar imageBernd Bausch ( 2018-07-04 18:40:11 -0600 )edit

I checked, No VLANs in my external network. I installed the controller in a virtual machine in virtual box and i used a network bridge to connect it to the management LAN.

The compute nodes are physical machines. Cnotroller:192.168.2.116 Compute1:192.168.2.117 Compute2: 192.168.1.118

amirdhaoui gravatar imageamirdhaoui ( 2018-07-05 06:58:08 -0600 )edit

I followed exactly the guide to install neutron option 2 and I made no changes

amirdhaoui gravatar imageamirdhaoui ( 2018-07-05 08:07:35 -0600 )edit

Long ago, I had exactly the same problem with a Virtualbox-based setup: traffic to instances seemed to be swallowed by the Vbox network. Try another virtualization technology. I can confirm that it works well with KVM.

Bernd Bausch gravatar imageBernd Bausch ( 2018-07-05 08:26:44 -0600 )edit