Ask Your Question
0

How to change the default port for vnc?

asked 2018-07-01 17:44:59 -0500

johnpham gravatar image

I am trying to reconfigure the nova-novncproxy server to listen to port 5985 instead of 6080. This is because the openstack nodes are residing on a separate network in front of our corp firewall which only allowed a handful of ports, 5985 being one of them. I reconfigured the [vnc] section in /etc/nova/nova.conf on the compute node as follow: [vnc]

enabled = True
server_listen = 0.0.0.0
server_proxyclient_address = $my_ip
novncproxy_base_url = http://10.204.16.150:5985/vnc_auto.html

Restart the nova services on both controller and compute, restart apache service. I even reboot the whole thing, but doesn't work. nova-novncproxy is still listening on 6080:

root@controller:~# lsof -i :6080
COMMAND    PID USER   FD   TYPE DEVICE SIZE/OFF NODE NAME
nova-novn 2295 nova    4u  IPv4  20957      0t0  TCP *:6080 (LISTEN)

nothing is listening on 5985:

root@controller:~# lsof -i :5985
returned nothing

How do I correctly configure vnc to listen to a different port?

Thanks so much in advance

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-12-13 01:49:03 -0500

nicholas666 gravatar image

You may have underconfigured novncproxy_port

novncproxy_host = $my_ip novncproxy_port = 6080 server_listen = $my_ip server_proxyclient_address = $my_ip novncproxy_base_url = https://$my_ip:6080/vnc_auto.html

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-07-01 17:44:22 -0500

Seen: 125 times

Last updated: Jul 01 '18