Ask Your Question
0

Unable to delete snapshots in ceph from cinder

asked 2018-06-13 03:40:25 -0600

Robby gravatar image

Hi, I am using openstack pike with ceph backend, when I try to delete snapshots or images from dashboard, it says permission Error, How to say cinder to create snapshots unprotected by default? (or) How to ask cinder to unprotect the snapshots and delete when requested?

ERROR oslo_messaging.rpc.server PermissionError: error unprotecting snapshot volume-3d57031e-a467-4dc8-8640-a15d9cbf1f6d@snapshot-0af999d7-1b89-4b10-b3eb-0eccbbd388b9 2018-06-06 20:23:27.136 6185 INFO cinder.volume.manager [req-0c9397da-edea-427c-9fc9-4fd2dc1208e9 k202059 72f5eabc80c44aa0ba990b57b98745be - default default] Detaching volume 3d57031e-a467-4dc8-8640-a15d9cbf1f6d from instance 5a9ba1aa-670d-414b-8d8e-0975b7966cf7.

edit retag flag offensive close merge delete

Comments

I think protected snapshots is correct, but maybe your cinder and glance clients don't have sufficient permissions to perform deleting operations. Can you paste the output of

node:~ #  ceph auth get client.glance
node:~ #  ceph auth get client.cinder

(assuming your clients are these two)

eblock gravatar imageeblock ( 2018-06-13 09:55:20 -0600 )edit

Please check below the output

Robby gravatar imageRobby ( 2018-06-13 10:43:40 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2018-06-13 10:38:30 -0600

Robby gravatar image

Thanks so much, this is what i see

[client.glance] key = AQArXJ5aM4xaLBAAeE2tN+a3a2N9iyM1sosYyA== caps mon = "allow r" caps osd = "allow class-read object_prefix rbd_childern, allow rwx pool=images" [root@openstack1 ~]# ceph auth get client.cinder exported keyring for client.cinder [client.cinder] key = AQCfXJ5aaxhqFRAAI1vqQGNkzW6jMD/Cp5YngQ== caps mon = "allow r" caps osd = "allow class-read object_prefix rbd_childern, allow rwx pool=volumes, allow rwx pool=vms, allow rx pool=images"

If I edit rbd.py it works nicely, but it is just a quick fix

edit flag offensive delete link more

Comments

Not sure if it's a typo, but I read "rbd_childern" instead of "rbd_children". If this is actually your configuration, it should work after you correct it.

eblock gravatar imageeblock ( 2018-06-14 09:46:30 -0600 )edit

super!! it works now, thanks a ton

Robby gravatar imageRobby ( 2018-06-14 10:16:34 -0600 )edit

It was a good catch, great help, once again thanks a lot

Robby gravatar imageRobby ( 2018-06-14 10:17:35 -0600 )edit

Great, I'm glad I could help :-)

eblock gravatar imageeblock ( 2018-06-15 02:06:10 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2018-06-13 03:40:25 -0600

Seen: 185 times

Last updated: Jun 13