Ask Your Question
0

RHOSP10 (Newton) - Gateway Timeout (HTTP 504)

asked 2018-06-10 02:48:51 -0600

updated 2018-06-10 03:45:58 -0600

Hi all, I am trying to install Red Hat OpenStack on my private laptop using VMs and custom networking. I actually tried to follow this guide.

I got stucked in importing the overcloud images:

[stack@ospd ~]$ openstack overcloud image upload --image-path /home/stack/images/ 
Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL.
Gateway Timeout (HTTP 504)

Also neutron is not giving me replies:

[stack@ospd ~]$ neutron subnet-list Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL. Gateway Timeout (HTTP 504)

What's going wrong ? It seems like I have some internal networking issue.

I tried to check httpd service:

[root@ospd ~]# service httpd status
Redirecting to /bin/systemctl status httpd.service
● httpd.service - The Apache HTTP Server
   Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
   Active: active (running) since sab 2018-06-09 14:04:38 EDT; 13h ago
     Docs: man:httpd(8)
           man:apachectl(8)
 Main PID: 1381 (httpd)
   Status: "Total requests: 0; Current requests/sec: 0; Current traffic:   0 B/sec"
    Tasks: 43
   CGroup: /system.slice/httpd.service
           ├─1381 /usr/sbin/httpd -DFOREGROUND
           ├─2291 /usr/sbin/httpd -DFOREGROUND
           ├─2292 /usr/sbin/httpd -DFOREGROUND
           ├─2293 keystone-admin  -DFOREGROUND
           ├─2294 keystone-admin  -DFOREGROUND
           ├─2295 keystone-main   -DFOREGROUND
           ├─2296 keystone-main   -DFOREGROUND
           ├─2297 /usr/sbin/httpd -DFOREGROUND
           ├─2298 /usr/sbin/httpd -DFOREGROUND
           ├─2299 /usr/sbin/httpd -DFOREGROUND
           ├─2300 /usr/sbin/httpd -DFOREGROUND
           ├─2301 /usr/sbin/httpd -DFOREGROUND
           ├─2302 /usr/sbin/httpd -DFOREGROUND
           ├─2303 /usr/sbin/httpd -DFOREGROUND
           ├─2304 /usr/sbin/httpd -DFOREGROUND
           ├─2305 /usr/sbin/httpd -DFOREGROUND
           ├─4011 /usr/sbin/httpd -DFOREGROUND
           ├─6364 /usr/sbin/httpd -DFOREGROUND
           └─6863 /usr/sbin/httpd -DFOREGROUND

giu 09 14:04:33 ospd.lab.com systemd[1]: Starting The Apache HTTP Server...
giu 09 14:04:38 ospd.lab.com systemd[1]: Started The Apache HTTP Server.

Keystone log is telling me that the AMQP server is unreachable:

2018-06-10 04:25:39.295 2296 ERROR oslo.messaging._drivers.impl_rabbit [req-644091d9-2c81-47d2-a193-509baa6412ca - - - - -] [c1d8367b-b90c-4313-b0ad-7a7517c78b05] AMQP server on 192.168.126.1:5672 is unreachable: [Errno 111] Connection refused. Trying again in 32 seconds. Client port: None

Rabbitmq server has issues with starting:

[root@ospd keystone]# systemctl status rabbitmq-server.service -l
● rabbitmq-server.service - RabbitMQ broker
   Loaded: loaded (/usr/lib/systemd/system/rabbitmq-server.service; enabled; vendor preset: disabled)
  Drop-In: /etc/systemd/system/rabbitmq-server.service.d
           └─limits.conf
   Active: failed (Result: exit-code) since sab 2018-06-09 14:04:53 EDT; 14h ago
  Process: 2418 ExecStop=/usr/lib/rabbitmq/bin/rabbitmqctl stop (code=exited, status=0/SUCCESS)
  Process: 1280 ExecStart=/usr/lib/rabbitmq/bin/rabbitmq-server (code=exited, status=1/FAILURE)
 Main PID: 1280 (code=exited, status=1/FAILURE)

giu 09 14:04:53 ospd.lab.com rabbitmqctl[2418]: attempted to contact: [rabbit@ospd]
giu 09 14:04:53 ospd.lab.com rabbitmqctl[2418]: rabbit@ospd:
giu 09 14:04:53 ospd.lab.com rabbitmqctl[2418]: * unable to connect to epmd (port 4369) on ospd: address (cannot connect to host/port)
giu 09 14:04:53 ospd.lab ...
(more)
edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2018-06-10 03:46:11 -0600

So I tried to restart the AMQP server:

[root@ospd keystone]# systemctl start rabbitmq-server
[root@ospd keystone]# systemctl status rabbitmq-server.service -l
● rabbitmq-server.service - RabbitMQ broker
   Loaded: loaded (/usr/lib/systemd/system/rabbitmq-server.service; enabled; vendor preset: disabled)
  Drop-In: /etc/systemd/system/rabbitmq-server.service.d
           └─limits.conf
   Active: active (running) since dom 2018-06-10 04:39:46 EDT; 5s ago
  Process: 2418 ExecStop=/usr/lib/rabbitmq/bin/rabbitmqctl stop (code=exited, status=0/SUCCESS)
 Main PID: 13045 (beam.smp)
   Status: "Initialized"
    Tasks: 73
   CGroup: /system.slice/rabbitmq-server.service
           ├─13045 /usr/lib64/erlang/erts-7.3.1.4/bin/beam.smp -W w -A 64 -P 1048576 -K true -- -root /usr/lib64/erlang -progname erl -- -home /var/lib/rabbitmq -- -pa /usr/lib/rabbitmq/lib/rabbitmq_server-3.6.3/ebin -noshell -noinput -s rabbit boot -sname rabbit@ospd -boot start_sasl -config /etc/rabbitmq/rabbitmq -kernel inet_default_connect_options [{nodelay,true}] -rabbit tcp_listeners [{"192.168.126.1",5672}] -sasl errlog_type error -sasl sasl_error_logger false -rabbit error_logger {file,"/var/log/rabbitmq/rabbit@ospd.log"} -rabbit sasl_error_logger {file,"/var/log/rabbitmq/rabbit@ospd-sasl.log"} -rabbit enabled_plugins_file "/etc/rabbitmq/enabled_plugins" -rabbit plugins_dir "/usr/lib/rabbitmq/lib/rabbitmq_server-3.6.3/plugins" -rabbit plugins_expand_dir "/var/lib/rabbitmq/mnesia/rabbit@ospd-plugins-expand" -os_mon start_cpu_sup false -os_mon start_disksup false -os_mon start_memsup false -mnesia dir "/var/lib/rabbitmq/mnesia/rabbit@ospd" -kernel inet_dist_listen_min 25672 -kernel inet_dist_listen_max 25672
           ├─13268 inet_gethost 4
           └─13269 inet_gethost 4

giu 10 04:39:36 ospd.lab.com systemd[1]: Starting RabbitMQ broker...
giu 10 04:39:41 ospd.lab.com rabbitmq-server[13045]: RabbitMQ 3.6.3. Copyright (C) 2007-2016 Pivotal Software, Inc.
giu 10 04:39:41 ospd.lab.com rabbitmq-server[13045]: ##  ##      Licensed under the MPL.  See http://www.rabbitmq.com/
giu 10 04:39:41 ospd.lab.com rabbitmq-server[13045]: ##  ##
giu 10 04:39:41 ospd.lab.com rabbitmq-server[13045]: ##########  Logs: /var/log/rabbitmq/rabbit@ospd.log
giu 10 04:39:41 ospd.lab.com rabbitmq-server[13045]: ######  ##        /var/log/rabbitmq/rabbit@ospd-sasl.log
giu 10 04:39:41 ospd.lab.com rabbitmq-server[13045]: ##########
giu 10 04:39:41 ospd.lab.com rabbitmq-server[13045]: Starting broker...
giu 10 04:39:46 ospd.lab.com systemd[1]: Started RabbitMQ broker.
giu 10 04:39:46 ospd.lab.com rabbitmq-server[13045]: completed with 6 plugins.

Uh! it seems like rabbitm-server can actually start! Let's see if image upload now works:

[stack@ospd ~]$ openstack overcloud image upload --image-path /home/stack/images/ 
Image "overcloud-full-vmlinuz" was uploaded.
+--------------------------------------+------------------------+-------------+---------+--------+
|                  ID                  |          Name          | Disk Format |   Size  | Status |
+--------------------------------------+------------------------+-------------+---------+--------+
| 055a3e5d-64d2-4030-abaf-0b7489a52b33 | overcloud-full-vmlinuz |     aki     | 6385968 | active |
+--------------------------------------+------------------------+-------------+---------+--------+
Image "overcloud-full-initrd" was uploaded.
+--------------------------------------+-----------------------+-------------+----------+--------+
|                  ID                  |          Name         | Disk Format |   Size   | Status |
+--------------------------------------+-----------------------+-------------+----------+--------+
| 9fe3880a-7a22-4051-9f39-f05e5608bbeb | overcloud-full-initrd |     ari     | 63021344 | active |
+--------------------------------------+-----------------------+-------------+----------+--------+

It is working!

So restarting the process solved the issue. Still, it's not clear to me why this happened.

edit flag offensive delete link more

Comments

"unable to connect to epmd (port 4369) on ospd: address (cannot connect to host/port)" might well be caused by epmd taking too long to start up, and the RabbitMQ service being too impatient. Perhaps there is a timeout setting somewhere in RabbitMQ that you can tune.

Bernd Bausch gravatar imageBernd Bausch ( 2018-06-10 04:09:38 -0600 )edit

Thanks about that! I will definitely look if tuning timeout of RabbitMQ fixes it (it is happening again after a while).

Luigi gravatar imageLuigi ( 2018-06-13 15:34:47 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-06-10 02:48:51 -0600

Seen: 163 times

Last updated: Jun 10