devstack+ Big proxy+ Floodlight It is not possible to ssh VMs

asked 2014-02-05 08:14:21 -0500

joshua gravatar image

updated 2014-02-07 09:37:25 -0500

smaffulli gravatar image

I am using Devstack+ Big Switch Rest Proxy Plugin. I am using a Single Node as Controller+Compute Floodlight controller is also run. I am able to ping the VM instances

But I am not able to ssh to the VM Instances using keypair

Localrc file

root@tellabs-kvm1:/opt/devstack# cat localrc
HOST_IP=192.168.195.244

ENABLED_SERVICES=g-api,g-reg,key,n-api,n-crt,n-obj,n-sch,n-cauth,mysql,rabbit,sysstat,n-cond,n-cpu,n-novnc,n-xvnc
disable_service c-api c-sch c-vol cinder
enable_service n-vol
ENABLED_SERVICES+=,heat,h-api,h-api-cfn,h-api-cw,h-eng

ENABLED_SERVICES+=,horizon

disable_service n-net
enable_service q-svc
enable_service q-dhcp
enable_service q-meta
enable_service quantum

Q_PLUGIN=bigswitch_floodlight
BS_FL_CONTROLLERS_PORT=127.0.0.1:8080
Q_OVS_USE_VETH=true
Q_USE_NAMESPACE=False
Q_ALLOW_OVERLAPPING_IP=False

DATABASE_PASSWORD=Comnet123
RABBIT_PASSWORD=guest
SERVICE_TOKEN=012345SECRET99TOKEN012345
SERVICE_PASSWORD=Comnet123
ADMIN_PASSWORD=Comnet123

UBUNTU HOST

root@tellabs-kvm1:~/.ssh# ssh -vvv -i devstack ubuntu@30.0.0.6
OpenSSH_5.9p1 Debian-5ubuntu1.1, OpenSSL 1.0.1 14 Mar 2012
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to 30.0.0.6 [30.0.0.6] port 22.
debug1: connect to address 30.0.0.6 port 22: No route to host
ssh: connect to host 30.0.0.6 port 22: No route to host

If I use Fedora vM instance too, the same problem

The log in the VM Instance is

cloud-init start-local running: Wed, 29 Jan 2014 10:16:55 +0000. up 4.79 seconds
no instance data found in start-local
ci-info: lo    : 1 127.0.0.1       255.0.0.0       .
ci-info: eth0  : 1 30.0.0.4        255.255.255.0   fa:16:3e:02:79:c2
ci-info: route-0: 0.0.0.0         30.0.0.1        0.0.0.0         eth0   UG
ci-info: route-1: 30.0.0.0        0.0.0.0         255.255.255.0   eth0   U
ci-info: route-2: 169.254.169.254 30.0.0.2        255.255.255.255 eth0   UGH
cloud-init start running: Wed, 29 Jan 2014 10:16:56 +0000. up 5.48 seconds
2014-01-29 10:17:46,645 - util.py[WARNING]: 'http://169.254.169.254/2009-04-04/meta-data/instance-id' failed [50/120s]: url error [timed out]
2014-01-29 10:18:37,698 - util.py[WARNING]: 'http://169.254.169.254/2009-04-04/meta-data/instance-id' failed [101/120s]: url error [timed out]
2014-01-29 10:18:55,718 - util.py[WARNING]: 'http://169.254.169.254/2009-04-04/meta-data/instance-id' failed [119/120s]: url error [timed out]
2014-01-29 10:18:56,719 - DataSourceEc2.py[CRITICAL]: giving up on md after 120 seconds

no instance data found in start
Skipping profile in /etc/apparmor.d/disable: usr.sbin.rsyslogd
 * Starting AppArmor profiles       [80G [74G[ OK ]

How do I make the VM instance access the metadata server?

edit retag flag offensive close merge delete

Comments

you can ping 30.0.0.6 and you cannot ssh into that same IP? Edit your question to be more specific.

smaffulli gravatar imagesmaffulli ( 2014-02-06 17:14:35 -0500 )edit