Ask Your Question
0

Issue with IPv6 address assignment on provider network with Windows instances

asked 2018-06-05 09:02:28 -0500

osborng gravatar image

I'm running OpenStack Queen (fresh install) and have a provider network that provides both IPv4 and IPv6 addresses. The IPv6 addresses are provided by an upstream router that uses RAs "Assisted Mode". All of the Linux instances attached to the provider network obtain the correct IPv4 and IPv6 addresses and match what is shown for the IP address listed on the dashboard. For some reason, the Windows instances (currently Windows 7 and Windows 2012 R2) obtain the correct IPv4 address, but obtain a different IPv6 address than what's shown in the dashboard (the IPv6 address is on the correct network, just not what has been assigned to the instance). Because the address doesn't match, the instance cannot communicate on IPv6. If I manually set the IPv6 address in the instance to what is shown as assigned in the dashboard, the Windows instances can communicate via IPv6. I have already disabled privacy extensions in the images, but they still get these alternate assigned IPv6 addresses. Has anyone run into this issue and know of a way to resolved it, other than manually setting the IPv6 address in the instances?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2018-06-06 10:35:45 -0500

osborng gravatar image

I figured out what was causing this. It's not really an OpenStack issue, but more of a Windows issue. If anyone else runs into this, here is how I resolved it.

  1. I changed my upstream RA device to the following configuration (was assisted mode) "Stateless DHCP - RA Flags [other stateful], Prefix Flags [onlink, auto, router]". This is a pfSense firewall, so the option(s) in your device will probably differ.
  2. Disable IPv6 privacy extensions in the image with the following commands:
    • "netsh interface ipv6 set privacy state=disabled store=active"
    • "netsh interface ipv6 set privacy state=disabled store=persistent"
  3. Enable EUI-64 address assignment/disable randomize identifiers in Windows
    • "netsh interface ipv6 set global randomizeidentifiers=disabled store=active"
    • "netsh interface ipv6 set global randomizeidentifiers=disabled store=persistent"

Once these changes were made, the Windows instances were able to obtain the correct IPv6 assignment that matched what was being assigned by OpenStack.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2018-06-05 09:02:28 -0500

Seen: 45 times

Last updated: Jun 06