Ask Your Question
0

Glance change the default tmp download directory

asked 2018-06-04 02:34:12 -0600

mike11 gravatar image

Hi All,

The setup that i have has a very limited hard drive space on the controller and when i upload a large image (through the horizon) the horizon keeps the image in /tmp. This causes my disk to get full (with 3.5 GB images). The best solution for me would be to be able to change the default download /tmp directory to a different directory, for example, to /mnt/tmp.

Thank you so much for any help. Michael

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2018-06-04 03:17:19 -0600

eblock gravatar image

Hi,

you are probably searching for this config option:

FILE_UPLOAD_TEMP_DIR = "/var/lib/glance/horizon/"

located under /srv/www/openstack-dashboard/openstack_dashboard/local/local_settings.py (on openSUSE).

edit flag offensive delete link more

Comments

Hi, Thank you for you answer! I tried this, but what happens is that it loads the image into the swap and then errors in the end which is strange. I added also the following line: FILE_UPLOAD_MAX_MEMORY_SIZE = '1', but it didn't help. Do you see anything that i am missing? Thanks,

mike11 gravatar imagemike11 ( 2018-06-04 06:00:18 -0600 )edit

This actually worked! My problem was the path /mnt/my_tmp which might be that it is not in the file system. i guess there is an issue with that. Thank you!

mike11 gravatar imagemike11 ( 2018-06-04 08:50:30 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-06-04 02:34:12 -0600

Seen: 37 times

Last updated: Jun 04