cinder-volume on icehouse complains "osapi_volume_workers must be integer greater than 1"

asked 2018-05-30 05:30:58 -0500

Mettacrawler gravatar image

I am using multi-node architecture Icehouse including network, controller, compute and cinder nodes. everything is working fine except creating cinder volumes which stuck in creating status and the only way to get rid of it is using cinder reset-state which gets the volume into status "available". the created volume can't be deleted unless using "force-delete" command and then restarting cinder node.

When I run cinder create --display_name NAME SIZE

I only see this particular error message in the log files :

2018-05-30 10:49:22.664 2864 WARNING keystoneclient.middleware.auth_token [-] Configuring auth_uri to point to the public identity endpoint is required; clients may not be able to authenticate against an admin endpoint
2018-05-30 10:49:22.667 2864 WARNING cinder.service [-] Value of config option osapi_volume_workers must be integer greater than 1.  Input value ignored.

which comes from cinder-api log file on cinder node and

2018-05-30 11:08:06.613 1209 WARNING cinder.context [-] Arguments dropped when creating context: {'user': None, 'tenant': None, 'user_identity': u'- - - - -'}

which comes from cinder-scheduler log file in controller node.

here is my configuration file in cinder node:

[DEFAULT]
rootwrap_config = /etc/cinder/rootwrap.conf
api_paste_confg = /etc/cinder/api-paste.ini
iscsi_helper = tgtadm
volume_name_template = volume-%s
volume_group = cinder-volumes
verbose = True
auth_strategy = keystone
state_path = /var/lib/cinder
lock_path = /var/lock/cinder
volumes_dir = /var/lib/cinder/volumes
rpc_backend = rabbit
rabbit_hosts = controller
rabbit_port = 5672
rabbit_userid = guest
rabbit_password = xxx
glance_host = controller
[keystone_authtoken]
auth_uri = http://controller:5000
auth_host = controller
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = cinder
admin_password = xxx
[database]
connection = mysql://cinder:xxx@controller/cinder

and this is my cinder configuration file in controller node:

[DEFAULT]
control_exchange = cinder
notification_driver = cinder.openstack.common.notifier.rpc_notifier
rootwrap_config = /etc/cinder/rootwrap.conf
api_paste_confg = /etc/cinder/api-paste.ini
iscsi_helper = tgtadm
volume_name_template = volume-%s
volume_group = cinder-volumes
verbose = True
auth_strategy = keystone
state_path = /var/lib/cinder
lock_path = /var/lock/cinder
volumes_dir = /var/lib/cinder/volumes
rpc_backend = rabbit
rabbit_host = controller
rabbit_port = 5672
rabbit_userid = guest
rabbit_password = xxx
[database]
connection = mysql://cinder:xxx@controller/cinder
[keystone_authtoken]
auth_uri = http://controller:5000
auth_host = controller
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = cinder
admin_password = xxx

I appreciate if someone can help me with this.

edit retag flag offensive close merge delete