missing value auth-url required for auth plugin password

asked 2018-05-25 01:37:55 -0500

Pauline.B gravatar image

Hello,

I have this message missing value auth-url required for auth plugin password when I Try to create a domain by this command: openstack project create --domain default --description "Service Project" service

I create a file in /etc/keyston, it's admin-openrc.sh

$ export OS_USERNAME=admin $ export OS_PASSWORD=ADMIN_PASS $ export OS_PROJECT_NAME=admin $ export OS_USER_DOMAIN_NAME=Default $ export OS_PROJECT_DOMAIN_NAME=Default $ export OS_AUTH_URL=http://controller:35357/v3 $ export OS_IDENTITY_API_VERSION=3

(I Follow instructions for installation https://docs.openstack.org/ocata/fr/install-guide-ubuntu/keystone-install.html#install-and-configure-components (https://docs.openstack.org/ocata/fr/i...))

Do you have a solution?

I'm sorry for my english, I'm a French student and I need to deploy an openstack for my university's project. Thanks for your answers

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2020-07-10 13:44:57 -0500

telukir gravatar image

For this you need to know your openrc file(here assuming admin-openrc.sh your openrcfile). If you know it then source it. If you don't have any errors after sourcing you should be able to use openstack command

source admin-openrc.sh

Hope above command solves your issue

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2018-05-25 01:37:55 -0500

Seen: 2,973 times

Last updated: May 25 '18