Ask Your Question
0

Settings for physical_interface_mappings

asked 2018-05-22 13:13:07 -0500

codylab gravatar image

updated 2018-05-22 13:13:45 -0500

I am confused by the physical_interface_mappings line in the linuxbridge_agent.ini file.

If my Compute node have no direct connection to the provider network (i.e. all outbound traffic must be proxied through the controller/network node via an overlay network), should I just comment out the "physical_interface_mappings =" line on the compute node, then set "physical_interface_mappings = provider:eth2" on the Controller/Network node (assuming eth2 is connected to provider network)?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2018-05-23 03:04:48 -0500

eblock gravatar image

To me it sounds like a misunderstanding of provider networks and the concept of floating IPs.

Instances reside on compute nodes, so either the compute node needs the connection to a provider network to avoid sending all traffic through the network node if the instance is supposed to have its interface in this network, or you simply talk about floating IPs where VMs have a connection to the outside world but all traffic is handled by the network node.

Either way, you need at least the real network device (bondX, ethX) in the physical_interface_mappings config option to tell neutron which interface to use for the virtual devices.

edit flag offensive delete link more

Comments

Hi eblock, thank you for answering my question. What got me confused is that if I do not have a NIC for the provider network on the compute node, what do I put in the physical_interface_mappings for that compute node?

codylab gravatar imagecodylab ( 2018-05-23 07:16:32 -0500 )edit

My setup for the controller/network node has 3 NICs (for management/api, overlay, and provider). My compute node has 2 NICs (for management/api and overlay). North-south traffic is carried out via controller/network node, with floating IP.

codylab gravatar imagecodylab ( 2018-05-23 07:20:53 -0500 )edit

This is my config for the physical_interface_mappings:

[linux_bridge]
physical_interface_mappings = physnet1:bond0, prov1:vlanXXX, prov2:vlanXXY, prov3:vlanXYY

So you need at least the physnet1 mapping to the real physical device on the compute node.

eblock gravatar imageeblock ( 2018-05-24 02:36:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2018-05-22 13:13:07 -0500

Seen: 220 times

Last updated: May 23 '18