upgrade OpenStack to Queens from Ocata

asked 2018-05-17 10:11:53 -0500

minimike gravatar image

Hi there

I have runned OpenStack Ocata on Ubuntu 17.09. Now I have upgraded my operating systems from Ubuntu 17.09 to Ubuntu 18.04. That means also an upgrade for OpenStack to Queens from Ocata.

I think the databases are upgraded at all. but it seems the are some changed API Enpoints. Currently I got in stuck because nova is not running properly.

UnsupportedVersion: Endpoint does not support RPC version 5.0. Attempted method: build_and_run_instance

Is they a manual ore something helpful available they describes the reqired tasks?

edit retag flag offensive close merge delete

Comments

Not sure if it's really recommended to skip a version during upgrade (Pike), but it could be a package that was not upgraded. Or is it a config option you forgot to change? glance-api:

enable_v1_api = false
enable_v2_api = true
enable_v1_registry = false
enable_v2_registry = true
eblock gravatar imageeblock ( 2018-05-18 02:47:05 -0500 )edit