Ask Your Question

Magnum enable cloud-controller-manager

asked 2018-05-15 20:34:10 -0500

don gravatar image

updated 2018-05-15 20:51:34 -0500

I see that magnum creates a file /etc/kubernetes/kube_openstack_config. But this doesn't seem to be used. I'm finding that my external-ip stay pending for ever on services using e.g.

It seems that there should be a cloud-controller-manager running (, presumably w/ some access to that file.

The kube_openstack_config seems to be setup properly. And heat's bit is working (e.g. creating instances, creating load-balancers for the API). But the post-heat bits are not working.

External cloud managers were intro into 1.6 of Kubernetes, and I'm on 1.9.3.

I'm not clear on whether magnum should have enabled this, or whether I am to do it manually and feed it that file. has the docs on the subject I guess.

Does anyone have any input? is anyone actually using magnum?

from looking @ the code, it seems like TRUST_ID needs to be set (and its empty, so the bash script on master/minion have not populated). I do have

magnum-api/magnum.conf:trustee_domain_admin_password = XXXX                                                                          
magnum-api/magnum.conf:trustee_domain_admin_name = magnum_trustee_domain_admin                                                                                           
magnum-api/magnum.conf:trustee_domain_name = magnum

i'm not sure if that is the trust_id referred to. If i do a 'trust list', I see two (both for heat). Was one of them meant to be passed?

I also see and suggests that we are still using the inbuilt provider.

What is the TRUST_ID referred to the script? How would I populate that?

edit retag flag offensive close merge delete


it seems enable_cluster_user_trust is not set, its not in globals.yml. And, its required.

don gravatar imagedon ( 2018-05-17 09:06:32 -0500 )edit

So where did you guys get the fedora version? on the 28 build of Fedora atomic there are a lot of crashes & core dumps caused internally on the manager node. All the links on the magnum user guide for the images are dead and the "bug" reporting is turned off.

hardcore-01 gravatar imagehardcore-01 ( 2018-06-24 01:30:11 -0500 )edit

1 answer

Sort by ยป oldest newest most voted

answered 2018-05-17 13:28:12 -0500

don gravatar image

OK, for the record, the answer is, you need:

[trust] cluster_user_trust=True

in your magnum config. I'm using kolla, so adding this to the override. Without it, magnum kubernetes doesn't work w/ openstack.

edit flag offensive delete link more


thanks - this fixed my issue, I have noticed that that kube-controller-manager is running as a process on kube master, also, there is no storage class configured, we need to create the cinder storage class before we can attach persistient volumes!

rduncan-t gravatar imagerduncan-t ( 2018-11-23 10:26:05 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2018-05-15 20:34:10 -0500

Seen: 459 times

Last updated: May 17 '18