Ask Your Question
0

DevStack install fails on pip version

asked 2018-05-04 08:23:22 -0600

elsonico gravatar image

I have Ubuntu 16.0.4 LTS with upgrades running on physical machine.

I get this error in middle of the ./stack.sh

"You are using pip version 9.0.3, however version 10.0.1 is available. You should consider upgrading via the 'pip install --upgrade pip' command."

When I do 'sudo pip install --upgrade pip' it upgrades to 10.0.1 but next time I run stack.sh, I get exactly same error.

I've been starting all over several times and cleaned everything, but I get this everytime.

I had older DevStack running for very long time, but wanted to start over and now I got this.

Any suggestions greatly appreciated.

edit retag flag offensive close merge delete

Comments

Hi, have you solved the problem?

Ness gravatar imageNess ( 2018-08-08 15:38:55 -0600 )edit

I don't know if this problem persists after three months, but it's actually not a problem. The "error" message is just information that a newer version of pip is available, but the older version should work fine.

Bernd Bausch gravatar imageBernd Bausch ( 2018-08-08 19:01:06 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2018-08-08 14:29:55 -0600

Ness gravatar image

Hi, have you solved the problem?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-05-04 08:23:22 -0600

Seen: 392 times

Last updated: Aug 08 '18