Ask Your Question
0

Can't set up OpenStack with OpenDaylight using Devstack

asked 2018-04-29 03:03:47 -0500

nakrule gravatar image

updated 2018-04-30 03:19:05 -0500

EDIT: Updated my local.conf to add HOST_IP, like Bernd told me.

Hi, I'm trying since two days to set up an all-in-one OpenStack cloud with OpenDaylight on an Ubuntu 16.04 VM (using VMware Fusion 10 on OSX).

According to the official ODL http://docs.opendaylight.org/en/stable-nitrogen/submodules/netvirt/docs/openstack-guide/openstack-with-netvirt.html#id3 (documentation), I just need to add the following to my local.conf:

enable_plugin networking-odl http://git.openstack.org/openstack/networking-odl <branch>
ODL_MODE=allinone
Q_ML2_PLUGIN_MECHANISM_DRIVERS=opendaylight,logger
ODL_GATE_SERVICE_PROVIDER=vpnservice
disable_service q-l3
ML2_L3_PLUGIN=odl-router
ODL_PROVIDER_MAPPINGS={PUBLIC_PHYSICAL_NETWORK}:<external linux interface>

The first problem I had was loosing internet at some point when running stack.sh. So I added another network interface to my VM, like that (ens33 is used to access Internet):

nakrule@ubuntu:~$ ifconfig 
ens33     Link encap:Ethernet  HWaddr 00:0c:29:07:53:ad  
          inet addr:192.168.4.169  Bcast:192.168.4.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:fe07:53ad/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:923772 errors:0 dropped:0 overruns:0 frame:0
          TX packets:193393 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1366227544 (1.3 GB)  TX bytes:12688472 (12.6 MB)

ens38     Link encap:Ethernet  HWaddr 00:0c:29:07:53:b7  
          inet addr:192.168.100.100  Bcast:192.168.100.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:fe07:53b7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:266 errors:0 dropped:0 overruns:0 frame:0
          TX packets:74 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:24954 (24.9 KB)  TX bytes:7947 (7.9 KB)

And set my local.conf to this:

[[local|localrc]]
ADMIN_PASSWORD=secret
DATABASE_PASSWORD=$ADMIN_PASSWORD
RABBIT_PASSWORD=$ADMIN_PASSWORD
SERVICE_PASSWORD=$ADMIN_PASSWORD
HOST_IP=192.168.100.100

enable_plugin networking-odl http://git.openstack.org/openstack/networking-odl master
ODL_MODE=allinone
Q_ML2_PLUGIN_MECHANISM_DRIVERS=opendaylight,logger
ODL_GATE_SERVICE_PROVIDER=vpnservice
disable_service q-l3
ML2_L3_PLUGIN=odl-router
ODL_PROVIDER_MAPPINGS={PUBLIC_PHYSICAL_NETWORK}:ens38

And I have the following error when running stack.sh:

2018-04-30 08:13:31.563 | Starting Neutron
+./stack.sh:main:1287                      configure_neutron_after_post_config
./stack.sh: line 1287: configure_neutron_after_post_config: command not found
++./stack.sh:main:1287                      err_trap
++./stack.sh:err_trap:556                   local r=127
++./stack.sh:err_trap:557                   set +o xtrace
stack.sh failed
Error on exit
World dumping... see /opt/stack/logs/worlddump-2018-04-30-081331.txt for details
[ERROR] /opt/stack/devstack/lib/glance:352 g-api did not start
Error on exit

What can I do to resolve this issue ? Thank you in advance for your help.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2018-04-29 23:07:01 -0500

I would think you need to set HOST_IP=192.168.1.111 in local.conf, if this is the address you want to use.

To find out why g-api didn't start, check the Glance API log. It could be under /opt/stack/logs, but I think systemd is used by default if you use a recent devstack, so that you can also check logs like this: sudo journalctl -u devstack@g-api.

edit flag offensive delete link more

Comments

Hi, I added my IP and it did the trick. However, now, I face another error:

configure_neutron_after_post_config: command not found

Any idea ? According to this link, it should be solved with the latest odl-networking: https://bugs.launchpad.net/networking-odl/+bug/1740007

nakrule gravatar imagenakrule ( 2018-04-30 02:09:44 -0500 )edit
1

I wouldn't know, but the bug description seems to say that you need to apply the newest local.conf.example:

enable_service neutron-api
enable_service neutron-metadata-agent
enable_service neutron-dhcp
Bernd Bausch gravatar imageBernd Bausch ( 2018-04-30 03:00:28 -0500 )edit

Hi, I used the following local.conf:

enable_service neutron-api
disable_service q-svc

Can you update your main answer with it, so I can accept it.

Thank you for your help, I was really struggling to have it working !

nakrule gravatar imagenakrule ( 2018-04-30 03:42:24 -0500 )edit

I am really glad I could help you. No need to upgrade my comment to an answer.

Bernd Bausch gravatar imageBernd Bausch ( 2018-04-30 19:02:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2018-04-29 03:03:47 -0500

Seen: 258 times

Last updated: Apr 30 '18