Ask Your Question
0

vitrage ERROR: You are not authorized to use global_index.

asked 2018-04-26 21:04:22 -0500

br gravatar image

I have installed vitrage in pike version of openstack. I followed the link https://docs.openstack.org/vitrage/pi... to install vitrage. In the installation procedure, there is a step to Copy policy.json to /etc/vitrage/; but unfortunately the link http://git.openstack.org/cgit/opensta... doesn't contain any file. So I skipped the step and continued further and now when I execute vitrage-collector command I am facing the following error:

vitrage.datasources.services HTTPForbidden: ERROR: You are not authorized to use global_index.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2018-04-27 06:11:06 -0500

updated 2018-04-27 06:17:22 -0500

Hi, the issue is in heat's policies.

By default is set to:

stacks:global_index: rule:deny_everybody

which block any global_index to any user. Vitrage requires this permission.

Will need to change the policie for something suitable for your environment like.

"stacks:global_index": "rule:deny_stack_user"

Regards

edit flag offensive delete link more

Comments

Thanks, It worked. now I am facing Authorization Failed (HTTP 403) when I execute vitrage topology show. Please find my vitrage.conf in the following attachment. http://paste.openstack.org/show/720076/ my credintial file as follows: http://paste.openstack.org/show/720077/

br gravatar imagebr ( 2018-04-28 23:22:06 -0500 )edit

try project_name = admin in conf file

Eyalb gravatar imageEyalb ( 2018-04-29 01:13:28 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2018-04-26 21:04:22 -0500

Seen: 260 times

Last updated: Apr 27 '18