I get Unauthorized message when i create a default domain in keystone

asked 2018-04-26 03:38:01 -0600

anonymous user

Anonymous

I use centos7.3 with kernel 3.10.0-693.21.1.el7.x86_64.

I'm following the openstack install doc step by step, but I get this message when I type

openstack domain create --description "An Example Domain" example

return message is :

The request you have made requires authentication. (HTTP 401) (Request-ID: req-edec0cf2-82ad-493f-8eeb-eb9b0aa5a4a6)

I check the keystone logs printing:

  • 2018-04-26 16:28:15.933 1953 INFO keystone.common.wsgi [req-a865ed43-33c8-4d6a-8c43-11ff3a52dd09 - - - - -] GET http://controller:35357/v3/
  • 2018-04-26 16:28:15.955 1949 INFO keystone.common.wsgi [req-edec0cf2-82ad-493f-8eeb-eb9b0aa5a4a6 - - - - -] POST http://controller:35357/v3/auth/tokens
  • 2018-04-26 16:28:16.841 1949 WARNING keystone.common.wsgi [req-edec0cf2-82ad-493f-8eeb-eb9b0aa5a4a6 - - - - -] Authorization failed. The request you have made requires authentication. from 172.16.2.42: Unauthorized: The request you have made requires authentication.

I don't know how to figure out ,the guides docs only tell us config [token] provider = fernet.

edit retag flag offensive close merge delete

Comments

Is Keystone listening on Port 35357? Check that with netstat -pan|grep 35357.

ICBeter gravatar imageICBeter ( 2018-05-07 02:41:58 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2018-04-26 03:50:29 -0600

ohofanz gravatar image

why is My question objected with This post is awaiting moderation

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-04-26 03:38:01 -0600

Seen: 206 times

Last updated: Apr 26 '18