devtsack ./stack.sh fails with at devstack@etcd.service

asked 2018-04-25 21:12:16 -0500

Konathalasuren gravatar image

Trying to run devstack on Ubuntu 16.04 VM using ./stack.sh

+lib/etcd3:start_etcd3:61                  sudo systemctl daemon-reload
+lib/etcd3:start_etcd3:62                  sudo systemctl enable devstack@etcd.service
Created symlink from /etc/systemd/system/multi-user.target.wants/devstack@etcd.service to 
/etc/systemd/system/devstack@etcd.service.
+lib/etcd3:start_etcd3:63                  sudo systemctl start devstack@etcd.service
Job for devstack@etcd.service failed because the control process exited with error code. See "systemctl status 
devstack@etcd.service" and "journalctl -xe" for details.
+lib/etcd3:start_etcd3:1                   exit_trap
+./stack.sh:exit_trap:515                  local r=1  
++./stack.sh:exit_trap:516                  jobs -p
+./stack.sh:exit_trap:516                  jobs=
+./stack.sh:exit_trap:519                  [[ -n '' ]]
+./stack.sh:exit_trap:525                  '[' -f /tmp/tmp.0IwC5vOcG5 ']'
+./stack.sh:exit_trap:526                  rm /tmp/tmp.0IwC5vOcG5
+./stack.sh:exit_trap:530                  kill_spinner
+./stack.sh:kill_spinner:425               '[' '!' -z '' ']'
+./stack.sh:exit_trap:532                  [[ 1 -ne 0 ]]
+./stack.sh:exit_trap:533                  echo 'Error on exit'
Error on exit
+./stack.sh:exit_trap:535                  type -p generate-subunit
+./stack.sh:exit_trap:536                  generate-subunit 1524706916 269 fail
+./stack.sh:exit_trap:538                  [[ -z /opt/stack/logs ]]
+./stack.sh:exit_trap:541                  /opt/stack/devstack/tools/worlddump.py -d /opt/stack/logs
World dumping... see /opt/stack/logs/worlddump-2018-04-26-014626.txt for details
+./stack.sh:exit_trap:550                  exit 1

sudo systemctl status devstack@etcd.service shows this:

stack@openstack-demo-vm:/opt/stack/devstack$ sudo systemctl status devstack@etcd.service
● devstack@etcd.service - Devstack devstack@etcd.service
Loaded: loaded (/etc/systemd/system/devstack@etcd.service; enabled; vendor preset: enabled)
Active: inactive (dead) (Result: exit-code) since Thu 2018-04-26 01:46:27 UTC; 1min 27s ago
Process: 122376 ExecStart=/opt/stack/bin/etcd --name openstack-demo-vm --data-dir /opt/stack/data/etcd --initial- 
cluster-state new --initial-cluster-token etcd-cluster-01 --initial-cluster openst
 Main PID: 122376 (code=exited, status=1/FAILURE)

Apr 26 01:46:26 openstack-demo-vm systemd[1]: devstack@etcd.service: Main process exited, code=exited, status=1/FAILURE
Apr 26 01:46:26 openstack-demo-vm systemd[1]: Failed to start Devstack devstack@etcd.service.
Apr 26 01:46:26 openstack-demo-vm systemd[1]: devstack@etcd.service: Unit entered failed state. 
Apr 26 01:46:26 openstack-demo-vm systemd[1]: devstack@etcd.service: Failed with result 'exit-code'.
Apr 26 01:46:27 openstack-demo-vm systemd[1]: devstack@etcd.service: Service hold-off time over, scheduling restart.
Apr 26 01:46:27 openstack-demo-vm systemd[1]: Stopped Devstack devstack@etcd.service.
Apr 26 01:46:27 openstack-demo-vm systemd[1]: devstack@etcd.service: Start request repeated too quickly.
Apr 26 01:46:27 openstack-demo-vm systemd[1]: Failed to start Devstack devstack@etcd.service.

lines 1-14/14 (END)

While etcd runs on the VM:

stack@openstack-demo-vm:/opt/stack/devstack$ systemctl status etcd
● etcd.service - etcd - highly-available key value store
Loaded: loaded (/lib/systemd/system/etcd.service; enabled; vendor preset: enabled)
Active: active (running) since Thu 2018-04-26 00:12:18 UTC; 1h 58min ago
 Docs: https://github.com/coreos/etcd
       man:etcd
Main PID: 4425 (etcd)
Tasks: 9
Memory: 9.3M
  CPU: 22.020s
CGroup: /system.slice/etcd.service
       └─4425 /usr/bin/etcd

What am i missing?

edit retag flag offensive close merge delete

Comments

Check the etcd log journalctl -u devstack@etcd.service

Bernd Bausch gravatar imageBernd Bausch ( 2018-04-29 17:02:09 -0500 )edit

I'm seeing these (4 times in the log):

devstack@etcd.service: Main process exited, code=exited, status=1/FAILURE
Failed to start Devstack devstack@etcd.service.
Konathalasuren gravatar imageKonathalasuren ( 2018-04-30 09:33:12 -0500 )edit

Also tried journalctl -b -u etcd shows..

the server is already initialized as member before, starting as etcd member...
..
starting server... [version: 2.2.5, cluster version: 2.2]
Started etcd - highly-available key value store.
Konathalasuren gravatar imageKonathalasuren ( 2018-04-30 11:31:18 -0500 )edit

I would have expected a message indicating that the etcd stopped, and why. Is it still runnung in spite of the FAILURE message?

Bernd Bausch gravatar imageBernd Bausch ( 2018-04-30 17:27:53 -0500 )edit

so i stopped etcd, and ran again. Seeing the same error. i'm using sudo -su stack and ./stack.sh. I can see it fail at (below).. the file /etc/systemd/system/devstack@etcd.service is under root.

  sudo systemctl start devstack@etcd.service
  Job for devstack@etcd.service failed
Konathalasuren gravatar imageKonathalasuren ( 2018-04-30 22:54:02 -0500 )edit