Ask Your Question
1

Hi EveryOne, I've tried Magnum in Queen version with centos and the Probelm is Kube-Matser in stucked in create in progress state????

asked 2018-04-22 04:11:47 -0500

anonymous user

Anonymous

updated 2018-04-22 04:19:33 -0500

Hi, Everyone, I've tried Magnum in Queen version with centos and the Problem is Kube-Master in stucked in creating in progress state???? The entire process like one master instance will be created with floating Ip and Private Ip, security group and when I see events in Heat stack where heat stack is in create progress and few things like etcd_lb, api_lb, network got completed in events. The only kube-master got stucked in create progress where it has stack resource group as OS::Heat::Resourcegroup and when I deep dive in Kube-master it shows one yaml called file:///usr/lib/python2.7/site-packages/magnum/drivers/k8s_fedora_atomic_v1/templates/kubemaster.yaml

When I'm checking kube-conductor logs it only shows kube-master create in progress and few lines which dont have any error.

I'm follwing below links to configure magnum in Openstack Queens https://docs.openstack.org/magnum/queens/install/install-rdo.html (https://docs.openstack.org/magnum/que...)

https://docs.openstack.org/magnum/queens/install/verify.html (https://docs.openstack.org/magnum/que...)

https://docs.openstack.org/magnum/queens/install/launch-instance.html (https://docs.openstack.org/magnum/que...)

When I'm verifying magnum operation it shows magnum-conductor up and running

Even the same cluster create_progress stuck result in Ocata ubuntu and Pike and queens centos

After a long time, the kubernetes cluster got failed, So, Pls help me anyone, Badly I wanted magnum. :)

edit retag flag offensive close merge delete

Comments

Try the log files on the kubemaster instance (https://kubernetes.io/docs/tasks/debu...).

Bernd Bausch gravatar imageBernd Bausch ( 2018-04-22 10:05:17 -0500 )edit

hello sir. is that resource PBM as its kubernetes cluster waiting for something as I given 10 GB of Ram for my VM where I'm running openstack cloud till magnum services????Ram for VM how much I can give sir and even when i started to run cluster the CPU % crossed 100!!!

juscloud gravatar imagejuscloud ( 2018-04-23 04:56:31 -0500 )edit

kubernetes-cluster-5kcd5buyhnlo-master-0 login: [ 449.823268] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.

juscloud gravatar imagejuscloud ( 2018-04-23 05:11:05 -0500 )edit

[ 449.959253] Bridge firewalling registered [ 450.856566] nf_conntrack version 0.5.0 (16384 buckets, 65536 max) [ 468.786606] IPv6: ADDRCONF(NETDEV_UP): docker0: link is not ready

juscloud gravatar imagejuscloud ( 2018-04-23 05:11:19 -0500 )edit

hello sir, above is my kubemaster instance logs, Kindly find it sir. Pls give some suggestions sir.

juscloud gravatar imagejuscloud ( 2018-04-23 05:12:12 -0500 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2018-07-12 08:52:38 -0500

garypen gravatar image

I hit this problem when trying to build a k8s cluster with TLS disabled. The root cause, I think, was that the /var/run/kubernetes directory on the cube master wasn't writeable by the kube user. When I modified it to 777, credentials appeared in the directory and the endpoint (:8080), sprang to life. I then hit the next set of problems...

BTW: I'm currently avoiding this issue by not disabling TLS in my k8s cluster. These bugs seem relevant:

https://bugs.launchpad.net/magnum/+bug/1714880 (https://bugs.launchpad.net/magnum/+bu...)

https://github.com/projectatomic/atomic-system-containers/issues/133 (https://github.com/projectatomic/atom...)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-04-22 04:11:47 -0500

Seen: 274 times

Last updated: Apr 22 '18