Ask Your Question
0

nova not talking to cinder

asked 2018-04-17 15:13:10 -0500

cbravo gravatar image

Hello guys,

I'm using openstack Pike on CentOS 7. When I try to create a new instance (volume storage backend), the process always times out and throws an error that it didn't finish creating. At first I thought it was some kind of issue with the storage being to slow but it isn't. When I look at the Volume list I see the volume created successfully and when I list my LUNs I see them successfully. Moreover, if I start an instance from that specific volume, it starts without issues.

It seems like the cinder volume does not notify nova to let it know it is done creating the volume. Any ideas as to what is going on? I went over the log files but didn't find anything weird. The backend is an EMC VNX if that helps at all.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2018-04-18 00:42:05 -0500

Deepa gravatar image

updated 2018-04-20 00:54:02 -0500

Try to increase block_device_allocate_retries value to 600 or high value in nova.conf and restart nova-compute service and see whether it helps.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-04-17 15:13:10 -0500

Seen: 58 times

Last updated: Apr 20 '18