Ubuntu 16: Installing Ceilometer, dependencies problem for gnocchi-api

asked 2018-04-18 04:22:39 -0500

Hello!

I currently have an OpenStack Queens cluster installed under Ubuntu 16.04. The modules installed are the basic ones: Nova, Neutron, Keystone, Glance and Horizon (with Ceph backend for Nova and Glance)

By following the official Ceilometer installation guide (https://docs.openstack.org/ceilometer/queens/install/install-base-ubuntu.html (https://docs.openstack.org/ceilometer...)), I get to the part where you have to install Gnocchi as metering data endpoint.

However, when I have to install the package: gnocchi-api via a simple apt-get, this one forces the removal of the following packages:

The following packages will be REMOVED:

keystone libapache2-mod-wsgi nova-placement-api openstack-dashboard

It seems there is a conflict between gnocchi-api running on Python 3 with WSGI applications in Apache but all OpenStack services are running under Python 2...

As much to say that the removal of these packages is rather problematic... Does anyone have any idea why this dependencies problem is happening? Or how to get around this problem?

Thank you

edit retag flag offensive close merge delete