Ask Your Question

devstack fails on glance image-create

asked 2014-02-03 08:47:14 -0500

Brenne gravatar image

updated 2015-07-05 22:43:30 -0500

smaffulli gravatar image


I'm trying to intall devstack but the script always fails at the same point when calling the command glance image-create. I receive a HTTP500 Internal Server Error. Here are the last few lines of the output of

This are the last few lines of screen-g-api.log:

I thought if mysql has something to do with it? I already increased the allocatable resources (buffer,cache) for mysql (/etc/mysql/my.cnf). Because I want to work with ironic due to localrc nova-network is disabled and neutron is enabled.

I already successfully set up devstack a few weeks ago, but since I installed my VM again I can't bring it up again.

I am a newbie to openstack. I am trying to install Openstack using devstack in my virtualbox (Ubuntu 12.04 32 bit). I ran ./ and get an httpinternalservererror. Please find the logs for reference here

--os-image-url image-create --name cirros-0.3.1-x86_64-uec --is-public True --container-format ami --disk-format ami
2014-02-06 08:57:54 HTTPInternalServerError (HTTP 500)
2014-02-06 08:57:55 ++ failed
2014-02-06 08:57:55 ++ local r=1
2014-02-06 08:57:55 +++ jobs -p
2014-02-06 08:57:55 ++ kill
2014-02-06 08:57:55 ++ set +o xtrace
2014-02-06 08:57:55 failed: full log in /opt/stack/logs/

I just ran ./ and ended up in that error. I think this is an issue with glance. However, I do not know much about openstack, so i am unable to give more details. I have pasted the logs. Any help would be appreciated.

edit retag flag offensive close merge delete


Check the logs to see what causes the error. Update the questions providing more details. And I suggest to use to paste long log files.

smaffulli ( 2014-02-06 16:40:15 -0500 )edit

Thanks for your response smafulli. I just ran ./ and ended up in that error. I think this is an issue with glance. However, I do not know much about openstack, so i am unable to give more details. I have pasted the logs here (

Aayush Agarwal ( 2014-02-06 22:44:28 -0500 )edit

Is this similar to: And can this be because of swift? glance gives https500 when swift is down?

openjastackstack ( 2014-02-07 08:23:04 -0500 )edit

I would suggest to first check if the glance database tables have been created! If not created, probably try running db_sync, that might give you some clues.

unmesh-gurjar ( 2014-02-07 10:58:43 -0500 )edit

2 answers

Sort by ยป oldest newest most voted

answered 2014-02-07 14:21:01 -0500

You might want to try a re-install of devstack, there is a script that will remove it entirely from your system, then just clone it back and run again to see if it works. I had a Devstack installl fail on me yesterday, different error and on a server I never run it on, I am going to be back on it later today to figure it out, but it was a different error as I was using Nova-network not Neutron. I may try enable Neutron to see what I get, but I wanted to see Nova-network work first.

edit flag offensive delete link more



Thanks Bill! I went one step further: I set up my devstack VM again, cloned devstack, run an voila. It worked :-) but actually this isn't quite the solution of the problem I think.

Brenne ( 2014-02-10 05:43:38 -0500 )edit

answered 2014-02-09 22:37:11 -0500

shum gravatar image

updated 2014-02-09 22:38:05 -0500

im facing the same issue :( tried to run anf again but in vain :( devstack glance not working

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower


Asked: 2014-02-03 08:47:14 -0500

Seen: 1,022 times

Last updated: Jul 05