Instance deployed on flat network is not accessible from outside

asked 2018-04-03 09:20:58 -0500

Sheetal gravatar image

updated 2018-04-03 17:08:28 -0500

Hi, I have installed RDO queens via packstack , My VM has single NIC = ens192 (172.16.82.224) and it is all-in-one topology (controller and compute on same node).

I used below command for installation:

nohup packstack --allinone --provision-demo=n --os-neutron-ovs-bridge-mappings=extnet:br-ex --os-neutron-ovs-bridge-interfaces=br-ex:ens192 \
--os-neutron-ml2-type-drivers=vxlan,flat,vlan --os-neutron-ml2-flat-networks=extnet --os-heat-install=y --keystone-admin-passwd=password &

Post installation, bridge br-ex is created.

I want to create flat network so that instances created can be accessible from outside and vice versa.

So I made below changes in ml2_conf.ini and openvswitch_agent.ini

file : ml2_conf.ini

type_drivers = local,flat,vlan
flat_networks = physnet1

File : openvswitch_agent.ini

integration_bridge=br-int
tenant_network_type = local,flat,vlan
network_vlan_ranges = physnet1
enable_tunneling = True
bridge_mappings = physnet1:br-ex
physical_interface_mappings = physnet1:br-ex

I created external network of type flat with subnet allocation pool start : 172.16.82.30, end: 172.16.82.35, dhcp_enabled=true (Note : If dhcp_enabled=false, deployed instance does not get IP)

I deployed a instance on this created external n/w , ifconfig command in instance shows the IP but I can not ping this IP from my machine,

This deployed instance can only ping controller node (172.16.82.224), it can not ping gateway IP : 172.16.82.1

I have applied security rules to deployed instance.

Can some one help me what should I do to reach IP from outside ?

edit retag flag offensive close merge delete

Comments

Some config values can’t be changed after deploying Neutron. For example, see the warning message in the installation guide.

Bernd Bausch gravatar imageBernd Bausch ( 2018-04-03 17:06:17 -0500 )edit

Try setting the correct parameters in the packstack command.

Bernd Bausch gravatar imageBernd Bausch ( 2018-04-03 17:07:45 -0500 )edit