Openstack Lab instances not taking dhcp IP for eth0

asked 2018-03-28 03:20:11 -0600

Sehriban gravatar image

updated 2018-03-28 03:20:35 -0600

Hi Everyone,

When i create my instances with yaml file interface eth0 is not taking IP. Only Warning is:

  • dhcp-agent.log log that might be causing a problem “Could not load eutron.agent.linux.interface.BridgeInterfaceDriver”

Thanks Sehriban Alpaydin

edit retag flag offensive close merge delete

Comments

When you ask Google what it thinks of this message, it tells you that it’s probably harmless. Most likely, your problem is caused by Neutron misconfiguration.

Does this only happen when launching instances via Heat, or also manually?

Bernd Bausch gravatar imageBernd Bausch ( 2018-03-28 07:52:33 -0600 )edit

In manual instance creation, if i gave keypair then problem occurs, otherwise eth0 taking dhcp address.

Sehriban gravatar imageSehriban ( 2018-03-28 08:40:57 -0600 )edit

This is odd. Still, start with setting an IP address manually inside the instance. If you get connectivity, something is wrong with your DHCP setup.

If not, you have a different network config problem. Trace for DHCP requests at various points between the instance and the DHCP server(s).

Bernd Bausch gravatar imageBernd Bausch ( 2018-03-29 00:40:16 -0600 )edit