Ask Your Question
0

[ocata] [magnum] [neutron] failing to create a cluster on "provider" network

asked 2018-03-20 05:56:54 -0500

On our ocata openstack install, we've chosen to configure the neutron "option1" https://docs.openstack.org/ocata/inst... "Provider networks" (so not the option with vxlan https://docs.openstack.org/ocata/inst...)

This is quite nice and simple for VMs, they get the flat internal IP and we get less network complexity.

Now, we're trying to install and use magnum https://docs.openstack.org/ocata/inst... (which by the way doesn't seem to mention that it requires heat - which we installed for it). The "test the install" part says that creating a subnet is optional https://docs.openstack.org/project-in... so we skipped that.

The template looks like this (trying to replace the external-network from public to provider)

magnum cluster-template-create --name swarm-cluster-template     \
                 --image fedora-atomic-ocata                \
                 --keypair arthur \
                 --external-network provider  \
                 --dns-nameserver 8.8.8.8   \
                --master-flavor m1.small   \
                --flavor m1.small  \
                 --coe swarm

For the creation of the cluster we get an error :

  magnum cluster-create --name swarm-cluster \
                        --cluster-template swarm-cluster-template

Here is the status_reason :

 ERROR: Failed to validate: : resources.network: : HEAT-E99001 Service neutron is not available for resource type Magnum::Optional::Neutron::RouterInterface, reason: Required extension router in neutron service is not available.

So my question is this : is it possible to get magnum to work with the provider networks / flat approach or if we want to use it do we have to switch to the vxlan neutron approach ?

edit retag flag offensive close merge delete

1 answer

Sort by » oldest newest most voted
0

answered 2018-03-20 06:54:55 -0500

Magnum sets up its own tenant network, to which the container hosts are then connected. Unfortunately, you need to configure “option 2” in your cloud as well.

It’s documented in the user guide, though a bit hidden in the explanation for the external-network option:

The servers in the cluster will be connected to a private network and Magnum will create a router between this private network and the external network.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2018-03-20 05:56:54 -0500

Seen: 129 times

Last updated: Mar 20 '18