Cannot to verify openstack glance service.

asked 2018-03-13 06:29:24 -0600

Shahid gravatar image

updated 2018-03-13 10:35:58 -0600

I followed Openstack Queens installation and got stuck on verifying Glance service. Error which I am getting while creating image is

HTTPInternalServerError (HTTP 500)

After this I ran the same command with debug and got this.

Starting new HTTP connection (1): controller
enter code here`http://controller:9292 "GET /v2/schemas/image HTTP/1.1" 500 0
Request returned failure status 500.
HTTPInternalServerError (HTTP 500)

The glance-api logs are as follows DiscoveryFailure: Could not determine a suitable URL for the plugin

2018-03-13 09:34:40.803 32590 INFO eventlet.wsgi.server [-] ***.***.***.*** - - [13/Mar/2018 09:34:40] "GET /v2/schemas/image HTTP/1.1" 500 139 0.006429
2018-03-13 09:34:54.153 32590 WARNING keystoneauth.identity.generic.base [-] Failed to discover available identity versions when contacting http://controller:35357. Attempting to parse version from URL.: ConnectFailure: Unable to establish connection to http://controller:35357: HTTPConnectionPool(host='controller', port=35357): Max retries exceeded with url: / (Caused by NewConnectionError('<urllib3.connection.HTTPConnection object at 0x7f3dd25ae590>: Failed to establish a new connection: [Errno 111] ECONNREFUSED',))

The command which I ran to create the image is

openstack image create "cirros"   --file cirros-0.3.5-x86_64-disk.img   --disk-format qcow2 --container-format bare   --public
edit retag flag offensive close merge delete

Comments

This error (Could not determine a suitable URL for the plugin) is usually caused by a missing auth_url entry in one of the config files. In this case check your glance and keystone configs, compare the auth_url options thoroughly with the docs, you'll probably find a difference to your configs.

eblock gravatar imageeblock ( 2018-03-13 08:46:13 -0600 )edit

can it be an error of the network ? , actually I don't have any management network configured because both the compute and controller node are not on same LAN network.

Shahid gravatar imageShahid ( 2018-03-13 09:19:25 -0600 )edit

One more thing, Is this case sensitive ? few places I have written "Default" and at few "default".

Shahid gravatar imageShahid ( 2018-03-13 09:23:06 -0600 )edit

ECONNREFUSED means that no process is listening at controller port 35357. My guess: Either the endpoint is incorrect, or Keystone is not running.

Bernd Bausch gravatar imageBernd Bausch ( 2018-03-13 09:24:54 -0600 )edit
1

Yes, it is case sensitive! you should use the exact same syntax as you did when you created the openstack domain. this applies to all your configs.

eblock gravatar imageeblock ( 2018-03-13 09:45:57 -0600 )edit