Ask Your Question
0

I got 500 INTERNAL SERVER ERROR CAN'T ACCESS DASHBOARD please help...

asked 2018-03-03 07:10:53 -0500

dilip.2632 gravatar image

This is my error file:

[Sat Mar 03 18:17:31.782182 2018] [wsgi:error] [pid 3855:tid 140044080199424] [remote 192.168.212.242:57749] __import__(name) [Sat Mar 03 18:17:31.782191 2018] [wsgi:error] [pid 3855:tid 140044080199424] [remote 192.168.212.242:57749] File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/settings.py", line 330, in <module> [Sat Mar 03 18:17:31.782207 2018] [wsgi:error] [pid 3855:tid 140044080199424] [remote 192.168.212.242:57749] from local.local_settings import * # noqa [Sat Mar 03 18:17:31.782217 2018] [wsgi:error] [pid 3855:tid 140044080199424] [remote 192.168.212.242:57749] File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/local/local_settings.py", line 127, in <module> [Sat Mar 03 18:17:31.782236 2018] [wsgi:error] [pid 3855:tid 140044080199424] [remote 192.168.212.242:57749] SECRET_KEY = secret_key.generate_or_read_from_file('/var/lib/openstack-dashboard/secret_key') [Sat Mar 03 18:17:31.782246 2018] [wsgi:error] [pid 3855:tid 140044080199424] [remote 192.168.212.242:57749] File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../horizon/utils/secret_key.py", line 68, in generate_or_read_from_file [Sat Mar 03 18:17:31.782262 2018] [wsgi:error] [pid 3855:tid 140044080199424] [remote 192.168.212.242:57749] key = read_from_file(key_file) [Sat Mar 03 18:17:31.782271 2018] [wsgi:error] [pid 3855:tid 140044080199424] [remote 192.168.212.242:57749] File "/usr/share/openstack-dashboard/openstack_dashboard/wsgi/../../horizon/utils/secret_key.py", line 49, in read_from_file [Sat Mar 03 18:17:31.782285 2018] [wsgi:error] [pid 3855:tid 140044080199424] [remote 192.168.212.242:57749] raise FilePermissionError("Insecure key file permissions!") [Sat Mar 03 18:17:31.782306 2018] [wsgi:error] [pid 3855:tid 140044080199424] [remote 192.168.212.242:57749] FilePermissionError: Insecure key file permissions!

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2018-03-05 14:37:41 -0500

Try changing the owner, group and mode of the Horizon's secret key file to horizon, horizon and 0600 respectively, like this:

chown horizon:horizon /var/lib/openstack-dashboard/secret_key
chmod 0600 /var/lib/openstack-dashboard/secret_key

You may have to do a restart of the apache2 service afterwards.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-03-03 07:09:55 -0500

Seen: 59 times

Last updated: Mar 05 '18