Ask Your Question
0

sudo packsack --allinone when asking for "Password: " which password is this??

asked 2018-03-01 18:23:32 -0500

MrQ gravatar image

Hello, I'm trying to use packstack --allinone to install openstack pike on my instance at GCP.

I was following this article:https://www.rdoproject.org/install/packstack/

In the last step, i.e. step 3 Step 3: Run Packstack to install OpenStack I've tried all sorts of password for this, including reset my root password, but none of them worked. Can anyone please help me with this issue?

Thanks in advance!!

edit retag flag offensive close merge delete

Comments

It should be this:

The installer will ask you to enter the root password for each host node you are installing on the network

(from https://www.rdoproject.org/install/pa...)

Try setting up ssh keys for localhost to prevent this from happening.

Bernd Bausch gravatar imageBernd Bausch ( 2018-03-02 01:10:48 -0500 )edit

Hi Bernd, thanks for your reply. I've tried reset my root password using "passwd" and used the new password to enter, but failed that step. Were you saying I should (Step 1) ssh-keygen -t rsa (Step 2) cat ~/.ssh/id_rsa.pub >> ~/.ssh/authorized_keys ?

MrQ gravatar imageMrQ ( 2018-03-02 13:04:13 -0500 )edit

That’s what I meant. Now, I can’t try it out right now, and my memory is hazy, thus I am leaving my input as a comment rather than an answer.

Bernd Bausch gravatar imageBernd Bausch ( 2018-03-02 17:05:57 -0500 )edit

I tried that as well but my problem remains. Do you know if there is anything to do with whether the ssh key pair was created with or without the passphrase option? I did it with passphrase, but I tried to enter the passphrase yet still failed at the installation step.

MrQ gravatar imageMrQ ( 2018-03-02 18:52:23 -0500 )edit

I doubt it has anything to do with the passphrase. Did you try a key without passphrase, or using the ssh-agent?

Bernd Bausch gravatar imageBernd Bausch ( 2018-03-04 08:50:03 -0500 )edit

1 answer

Sort by » oldest newest most voted
0

answered 2018-10-06 04:20:09 -0500

I had the same issue. What resolved my issue was nano /etc/ssh/sshd_config and set permitRootLogin to Yes

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-03-01 18:23:32 -0500

Seen: 314 times

Last updated: Mar 01 '18