Ask Your Question
0

router external interface is down

asked 2018-02-25 17:04:35 -0500

stefws gravatar image

Attempting to play with RDO Pike packstack --allinone and wonder how to get internet access from VMs from a 'public/provider network'. Have a router1 attached to both public and VM private networks, but it shows public NIC as down and thus can't ping any public IPs from router1.

Hints appreceicated, TIA.

Pls see Horisont Dashboard https://gbmc.dk/os_pubpri_router_issue.png (this png)

[root@localhost ~(keystone_admin)]# openstack router list
+--------------------------------------+---------+--------+-------+-------------+---------------+
| ID                                   | Name    | Status | State | Distributed | HA    |Project|
+--------------------------------------+---------+--------+-------+-------------+---------------+
| 3e76f0a1-4660-40b5-a61e-e5f13d9e8ef9 | router1 | ACTIVE | UP    | False       | False | 5f626635ef854dda8458bbcb31b40420 |
+--------------------------------------+---------+--------+-------+-------------+---------------+


[root@localhost ~(keystone_admin)]# openstack network list
+--------------------------------------+-------------+--------------------------------------+
| ID                                   | Name        | Subnets                              |
+--------------------------------------+-------------+--------------------------------------+
| 9e805aa5-be67-4fb7-ac05-e61c476f9f80 | private     | 058fe622-49a9-45d6-967a-2a0c33bc571e |
| 9efe1284-e0a7-44cb-acc9-ad1797fb371f | demo_public | 3b56ed5b-39a9-4691-9881-06421bd4ef3c |
+--------------------------------------+-------------+--------------------------------------+
edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2018-02-26 03:34:36 -0500

yas gravatar image

updated 2018-02-26 03:35:23 -0500

Try to create your public and private networks and your router using the Neutron CLI. Sometimes using Horizon dashboard causes problems.

  1. create external network :

    neutron net-create external-flat-network --provider:network_type flat --provider:physical_network extnet --router:external

  2. create a subnet :

    neutron subnet-create --name public-flat-subnet --enable_dhcp=False --allocation-pool=start=192.168.15.5,end=192.168.15.15 external-flat-network 192.168.15.0/24

  3. create router:

    neutron router-create router-flat-network

  4. setting gateway

    neutron router-gateway-set router-flat-network external-flat-network

  5. creating private network:

    neutron net-create private-management-network

  6. create private subnet

    neutron subnet-create --name private-management-subnet private-management-network 10.0.0.0/8

  7. Finally, connect your new private network to the public network through the router,

    neutron router-interface-add router-flat-network private-management-subnet

edit flag offensive delete link more

Comments

This work better rgs activating both router interfaces: https://gbmc.dk/os-neutron-active.png

stefws gravatar imagestefws ( 2018-03-01 01:09:19 -0500 )edit

The router instance has both NICs attached to br-int and both uses separate vlan ids. Wondering how to untag the external facing NIC (vlan=0) as the public subnet 'public-flat-subnet' is getting a vlan id > 0, and my external lan 192.168.15.0/24 is untagged?

stefws gravatar imagestefws ( 2018-03-01 01:31:41 -0500 )edit

Hello @stefws. Could you please paste the characteristics of your networks (vlan ID, types ...) ?

yas gravatar imageyas ( 2018-03-01 03:35:12 -0500 )edit

Thinking maybe to connect my router like L-K in figure at: http://rdoproject.org/networking/networking-in-too-much-detail/#direct-network-connection (http://rdoproject.org/networking/netw...)

https://gbmc.dk/os-ovs_br-int.png shows br-int port and their vlan IDs https://gbmc.dk/os-netns-router_ip-a.png shows the routers NICs

Let me know if

stefws gravatar imagestefws ( 2018-03-01 05:28:10 -0500 )edit

as state here: https://www.rdoproject.org/networking/neutron-with-existing-external-network/ (https://www.rdoproject.org/networking...) properly need to add 'flat' NW type to the ext NW as needed when provider NW is a simple flat network as most common. If you use a VLAN segment for external NW, you should add 'vlan' to the type driver list.

stefws gravatar imagestefws ( 2018-03-02 01:22:00 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-02-25 17:04:35 -0500

Seen: 71 times

Last updated: Feb 26