Ask Your Question
0

cinder volume type not being used, bug?

asked 2018-02-23 02:20:25 -0500

tonyp12 gravatar image

I have an image uploaded to openstack with a cinder_volume_type.

I am finding when using the horizon dashboard, things work great. The instance is built and the volume uses the cinder backend as configured. However when launching an instance via cli using the same image and same other values such as network etc, the instance is launched with a volume on the compute nodes disk within /var/lib/ directory.

to try and fix the problem, I set the default_volume_type in cinder.conf, as well as removed the default value of enabled_backend=tripleo_iscsi but still the same problem: CLI launched instances do not get a volume on the backend.

Additionally, when you look at the instance either in the cli or horizon, it says: | volumes_attached | |

So it's showing no volume attached as well.

How do I proceed on this?

edit retag flag offensive close merge delete

Comments

I guess your CLI command doesn’t specify that the root disk should be on a volume. How do you launch the instance?

Not sure if the openstack CLI client allows this. For an example using the nova client, see https://ask.openstack.org/en/question....

Bernd Bausch gravatar imageBernd Bausch ( 2018-02-23 03:34:56 -0500 )edit

Thanks again for your quick response :) The cli command, and subsequently our ansible script is wrong! See the answer below. :)

tonyp12 gravatar imagetonyp12 ( 2018-02-23 03:56:11 -0500 )edit

2 answers

Sort by » oldest newest most voted
0

answered 2018-02-23 03:44:57 -0500

Deepa gravatar image

updated 2018-02-23 03:47:14 -0500

What is the command used to launch instance ?

Also refer https://docs.openstack.org/ocata/user...

edit flag offensive delete link more
0

answered 2018-02-23 03:58:22 -0500

tonyp12 gravatar image

So, when using horizon it is actually creating a volume from an image and then booting the volume.

Our CLI was wrong, it was instead just booting the image (creating a local volume in /var/ on the compute node)

Correct way is to use one command to do two things: 1. create volume and then 2) boot instance from the volume:

nova boot newInstance \
--flavor m1.tiny \
--security-groups default \
--nic net-id=7ea5691a-7154-40e9-aaff-8f024a00dd4d \
--block-device source=image,id=79b63e42-9ab3-4e96-8d30-9477cfbb8bcb,dest=volume,size=100,shutdown=preserve,bootindex=0

But is the correct way to launch an instance "nova boot" or "openstack server create" ? I am using Pike

edit flag offensive delete link more

Comments

The correct way is the openstack client, but it still seems to be lacking a few (very few) features. Block device mapping used to be one of them, and your case might require the nova client. Perhaps an openstack help server create clarifies that (I have no cloud handy to check this).

Bernd Bausch gravatar imageBernd Bausch ( 2018-02-23 04:06:28 -0500 )edit

Horizon, by the way, has a switch to change its behaviour.

Bernd Bausch gravatar imageBernd Bausch ( 2018-02-23 04:09:17 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2018-02-23 02:20:25 -0500

Seen: 122 times

Last updated: Feb 23 '18