g-api did not start

asked 2018-02-17 08:47:25 -0600

Navya gravatar image

I have tried all the ways.But I can access the dashboard with the host ip address.But there are no images and flavors and no chance of creating an instance.Also while using openstack cli I am getting failed to connect http:127.0.0.1..... error showing identity failure.Please help me in successfully installing openstack for the sake of my project.I have to submit it in few days.

edit retag flag offensive close merge delete

Comments

There are many ways of deploying OpenStack. For an easy approach, select something like PackStack. If you need to continue using whatever your deployment is, you need to check the logs what went wrong.

Bernd Bausch gravatar imageBernd Bausch ( 2018-02-18 07:46:49 -0600 )edit

I am using ubuntu 10.04 and I need only devstack.I tried all the ways.But no use.Please tell me. Coming to log file it is even showing that g-api did not start.Why this error?I have seen so many sites to overcome it.But none helped me.

Navya gravatar imageNavya ( 2018-02-18 09:28:25 -0600 )edit

The g-api log file should contain clues why g-api doesn’t start.

Provide more error detail, also about the identity error. What precisely are you doing to cause the error, and what is the precise response, error message and relevant log content.

Bernd Bausch gravatar imageBernd Bausch ( 2018-02-18 16:01:36 -0600 )edit

It occurs to me that Ubuntu 10.04 is a bit old. Have you tried setting up your cloud on 16.04?

Bernd Bausch gravatar imageBernd Bausch ( 2018-02-18 23:47:35 -0600 )edit